[SOLVED] R6220 Problem upgrading from V19.07rc1 to rc2


I have tried upgrading my R6220 from rc1 to rc2 and version still states RC1 at the botton to each lucy page.

Could anyone explain if the device not upgrading is related to these lines of the release notes :
When upgrading from 19.07.0-rc1, if you are affected by the sysupgrade bug on ar71xx, you need to manually edit /lib/upgrade/stage2 and add /usr/share/libubox/jshn.sh to list of files in the install_file line (around line 51). This amounts to manually applying this patch.

If yes, could one provide a little bit more explanation as to sequence of operations to achieve that.

Quite possibly you are hit with that problem. The list of files used in the sysupgrade process is missing one file, which affects some routers (and maybe even not always).

There is not much more to explain. I split the sentence into three steps:

  1. login to the router with ssh
  2. use your usual text editor (e.g. "nano") to edit /lib/upgrade/stage2
  3. edit the file on line 51 (?) and add /usr/share/libubox/jshn.sh to the list that defines the files for the install_file list. (like you see in the linked patch, the line ends with "$RAMFS_COPY_DATA". add the filename before that, just like in the patch.)

The change (added text part with green highlighting) looks like this:

If you have no proper text editor installed, you can install nano easily:

opkg update
opkg install nano


So I did it and now am in RC2 :slight_smile:

for those not knowing the procedure is :

  • Update the stage2 file (as described in the release notes and above)
  • Upload the rc2 version again via lucy, and flash firmware

Should be rc2 upon reboot.

Thank you

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.