[SOLVED] Quagga with OSPFd not broadcasting/receiving any routes

I've got OSPF running on my Cisco gear, and talking consistently with a pfsense router passing several routes back and forth.

I recently started trying to configure Quagga on Openwrt, and though it seems to be running fine, it's not "doing" anything.

I've flushed the iptables entirely (it's an internal router with no NAT and two interfaces).

br-lan (standard bridge for OpenWRT)
eth0.2 static interface to my main network

br-lan 192.168.1.1
eth0.2 192.168.106.254

Both interfaces are accessible from either network, (I have added static routes until I can get OSPF working).
here is my ospfd.conf

hostname openwrt
password Sammiches
log file /tmp/ospf
!
!
interface br-lan
 ip ospf hello-interval 20
!
interface eth0.2
 ip ospf hello-interval 20

!
interface lo
!
!
router ospf
 ospf router-id 6.6.6.6
 interface br-lan
 interface eth0.2
```

The logs aren't much help since they seem to indicate they are missing interfaces clearly defined in the configs..

2020/11/02 03:51:39 OSPF: ASBR[Status:0]: Update
2020/11/02 03:51:39 OSPF: SPF: Scheduled in 0 msec
2020/11/02 03:51:41 OSPF: MPLS-TE(initialize_linkparams) Could not find corresponding OSPF Interface for br-lan
2020/11/02 03:51:41 OSPF: OSPF MPLS-TE: Abort update TE parameters: no Link Parameters for interface
2020/11/02 03:51:41 OSPF: MPLS-TE(initialize_linkparams) Could not find corresponding OSPF Interface for eth0.2
2020/11/02 03:51:41 OSPF: OSPF MPLS-TE: Abort update TE parameters: no Link Parameters for interface
2020/11/02 03:51:41 OSPF: MPLS-TE(initialize_linkparams) Could not find corresponding OSPF Interface for lo
2020/11/02 03:51:41 OSPF: OSPF MPLS-TE: Abort update TE parameters: no Link Parameters for interface
2020/11/02 03:51:41 OSPF: OSPFd 1.1.1 starting: vty@2604
2020/11/02 03:51:41 OSPF: MPLS-TE(initialize_linkparams) Could not find corresponding OSPF Interface for eth0
2020/11/02 03:51:41 OSPF: OSPF MPLS-TE: Abort update TE parameters: no Link Parameters for interface
2020/11/02 03:51:41 OSPF: MPLS-TE(initialize_linkparams) Could not find corresponding OSPF Interface for eth0.1
2020/11/02 03:51:41 OSPF: OSPF MPLS-TE: Abort update TE parameters: no Link Parameters for interface
2020/11/02 03:51:41 OSPF: MPLS-TE(initialize_linkparams) Could not find corresponding OSPF Interface for wlan0
2020/11/02 03:51:41 OSPF: OSPF MPLS-TE: Abort update TE parameters: no Link Parameters for interface

The question is, what am I doing wrong? The config is simple, why is it behaving badly?

What exactly are you expecting it to do? You have not configured any network, area, or redistribute.

Sorry, I was trying all sorts of things for a few days, and I have had different combinations of redistribute connected, and network definitions in the config file, none of which behaved any different.

Currently I have added "redistribute connected", and it's still perfectly happy doing nothing.

Here is what I currently have, and the output from sh ip ospf

router ospf
 ospf router-id 6.6.6.6
 network 192.168.1.0/24 area 0.0.0.0
 area 0.0.0.0 range 0.0.0.0/0
Area ID: 0.0.0.0 (Backbone)
   Number of interfaces in this area: Total: 1, Active: 1
   Number of fully adjacent neighbors in this area: 0
   Area has no authentication
   SPF algorithm executed 1 times
   Number of LSA 1
   Number of router LSA 1. Checksum Sum 0x00004965
   Number of network LSA 0. Checksum Sum 0x00000000
   Number of summary LSA 0. Checksum Sum 0x00000000
   Number of ASBR summary LSA 0. Checksum Sum 0x00000000
   Number of NSSA LSA 0. Checksum Sum 0x00000000
   Number of opaque link LSA 0. Checksum Sum 0x00000000
   Number of opaque area LSA 0. Checksum Sum 0x00000000

First of all where is 6.6.6.6 defined in your interfaces?
Second the network 192.168.1.0/24 doesn't participate to the ospf from my understanding. eth0.2 is connected to your main network where the other ospf routers are.
The area must match the area you have on the other routers.
Try this:

router ospf
 ospf router-id 192.168.1.1
 network 192.168.106.0/24 area 0.0.0.0
 redistribute connected

adjust the area, if it is not 0.

My Cisco stuff is configured like this

interface Vlan55
 ip address 192.168.106.2 255.255.255.0
 ip ospf 1 area 0.0.0.0
!
interface Vlan56
 ip address 192.168.108.2 255.255.255.0
 ip helper-address 192.168.108.1
 ip ospf 1 area 0.0.0.0
!
router ospf 1
 router-id 4.4.4.4
 redistribute connected

The router-ID is arbitrary, it doesn't have to correspond with an IP address, but the area is always 0.0.0.0 in my network.

I'll try your settings and see what happens.

-Chance

This seems to have worked...


interface br-lan
 ip ospf hello-interval 10
!
interface eth0
!
interface eth0.1
!
interface eth0.2
 ip ospf hello-interval 10
!
interface lo
!
interface wlan0
!
router ospf
 ospf router-id 192.168.1.1
 network 192.168.106.0/24 area 0.0.0.0
 redistribute connected

The router-id can be either manually configured, or the highest loopback IP or the highest non loopback IP if not configured. If you enable the name-lookup in ospf you'll see some weird name there with 6.6.6.6 and 4.4.4.4 ids. Better stick to the standards while you still learn something.

Give me an idea what "manually configured" means. I interpreted it as "it can be whatever you want as long as it's unique within the network".

I'm reading this now, it seems to answer the above question. Also this is for home network stuff, so please don't brand me as a lazy sysadmin :slight_smile:

http://blog.boson.com/bid/94434/how-to-tame-a-wild-ospf-topology-using-router-ids#:~:text=As%20long%20as%20a%20loopback,assigned%20to%20the%20physical%20interfaces.

Configuring the router-id with a value and not letting the process decide by itself.
You usually add there a distinctive address of the router, preferably a loopback which won't go down.

Home or work it doesn't matter, practice makes perfection! :wink:

I'm adding a loopback address and using 10.10.100.1-10.10.104.1 for the different routers, then letting the routerID's pick themselves.

The home network thing was just informational since I didn't want people thinking I was trying to do this stuff professionally and asking basic questions about routing :slight_smile:

Thanks for the assistance.

-Chance

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.