SOLVED: QMI - no IP address shown under LUCI

Dear developers,

I am using a Quectel EC25 modem in QMI mode, and I noticed that under LUCI the IP address of the QMI connection is not shown:

qmi_luci_no_ip

If I list the interfaces, the IP address is visible in CLI:

wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:100.77.11.109  P-t-P:100.77.11.109  Mask:255.255.255.252
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:3246992 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1264766 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:126255328 (120.4 MiB)  TX bytes:166399905 (158.6 MiB)

It is also interesting that MAC address is not shown, but in the kernel log during the driver initialization, there is a MAC address indicated:

[   49.544003] qmi_wwan 1-1.2:1.4: cdc-wdm0: USB WDM device
[   49.550332] qmi_wwan 1-1.2:1.4 wwan0: register 'qmi_wwan' at usb-ehci-platform-1.2, WWAN/QMI device, 02:60:57:42:09:93

If I try to retrieve the connection settings with UQMI, that also indicates the IP addresses correctly:

root@GL-MiFi:~# uqmi -d /dev/cdc-wdm0  --get-current-settings
{
        "pdp-type": "ipv4",
        "ip-family": "ipv4",
        "mtu": 1500,
        "ipv4": {
                "ip": "100.77.11.109",
                "dns1": "194.151.228.2",
                "dns2": "194.151.228.50",
                "gateway": "100.77.11.110",
                "subnet": "255.255.255.252"
        },
        "ipv6": {

        },
        "domain-names": {

        }
}

The modem otherwise works correctly, but it is a bit annoying that the IP address is not visible.

I am on platform ar71xx with kernel 4.9.96.

I am more than happy to try any suggestions, or beta test if there is a fix available.

Don't know anything about luci, but the mac address change is expected. The driver starts up in "802.3" mode, but is switched to "raw-ip" mode for the EC25. There are no L2 headers or mac addresses in raw-ip mode. That's the whole point: The IP packets are sent "bare" without any wrapping.

@bmork thanks for sehding light on the MAC address issue.

I am not sure what to do about the IP address issue. Should I file a bug report? Or maybe there is something to try? Is there anyone with the same issue with Quectel EC25?

By the way in modem mode the IP address is shown correctly, but the speed is significantly less then on QMI mode. It would be nice to fix this.

There is a fix on its way not yet merged:

https://github.com/openwrt/luci/pull/1683

I think this can be considered solved.