[SOLVED] Procps-ng (vtund) with glibc - strange issue

Hello community. Need your help again :expressionless:
I've compiled LEDE 17.01 with glibc, because some musl limitations and I see an issue with procps ng. Part of it (ps) has strange behavior

If I run some process (for example vtund $hostname $ipaddress), I can not see correct state of process.

It should be vtund connecting to .... and then vtund[c]: $hostname $tun_type $tunID but it shows only exactly what I run from cmd line
for example I run vtund $hostname $IP foo bar and I see in process list vtund $hostname $IP foo bar :slight_smile:
Tried procps-ng 3.12, 3.11 too

EDIT: Tried with busybox ps and the same behaviour. Does not show expected output.

I did remake again and it is solved. Strange :slight_smile:

Not procps bug but vtund bug and libbsd. Why vtund compiled with glibc need libbsd? Where is taken the -lbsd flag during configure?
staging_dir/toolchain-mipsel_24kc_gcc-5.4.0_glibc-2.24/lib -znow -zrelro conftest.c -lbsd