SOLVED: Problem with vlan config

good morning readers,

I am currently struggling with some configuration and my understanding of this topic itself. I have a Archer c7 with LEDE on it and configured three more vlans 10, 20 and 100. on my firewall the vlans have a dhcp server each.

also, i have three wlans "vlan10", "vlan20" and "vlan100" which represent vlan. when I connect over wlan I get working ip addresses and everything works fine, even the Internet. although when i connect via cable to the archer I get right ip addresses but no connection to the internet.

another problem I face is with my uplink - my archer has 10.44.100.253 (fw is set to 10.44.xxx.254) and the uplink runs through the wan port (which should be part of the switch itself). strangely I don't have Internet connection when I open a shell on the archer. also, I just can reach the archer when I connect to port 1 of the switch with a static address like 10.44.100.22. when I want to connect over port 4 (vlan100) it doesn't work.

I am sure this is a minor problem and I just don't see it. please find my config attached. ah, another question, how can I get rid of this vlan2 and everything wan related? the archer just should be ap... all my trys to remove the entries via Shell never worked, after reboot they were back again?!

thanks in advance!!!

ps: my firewall is switched off on the archer.

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fda7:5be5:8db9::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '10.44.100.253'
option gateway '10.44.100.254'
option broadcast '10.44.100.255'
option dns '10.44.100.254 8.8.8.8 8.8.4.4'
option _orig_ifname 'eth1 radio1.network1'
option _orig_bridge 'true'
option ifname 'eth0 eth0.2 eth1'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.2'

config interface 'wan6'
option proto 'dhcpv6'
option ifname 'eth0.2'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0 2'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '3'
option vid '10'
option ports '1t 3 6t'

config switch_vlan
option device 'switch0'
option vlan '4'
option vid '20'
option ports '1t 4 6t'

config switch_vlan
option device 'switch0'
option vlan '5'
option vid '100'
option ports '1t 5 6t'

config interface 'vlan100'
option proto 'none'
option type 'bridge'
option _orig_ifname 'eth0.100 wlan0-2'
option _orig_bridge 'true'
option ifname 'eth0 eth0.100'

config interface 'vlan10'
option proto 'none'
option ifname 'eth0.10'
option type 'bridge'

config interface 'vlan20'
option proto 'none'
option ifname 'eth0.20'
option type 'bridge'

/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option country 'US'

config wifi-iface 'default_radio0'
option device 'radio0'
option mode 'ap'
option encryption 'psk2'
option ssid 'vlan10'
option hidden '1'
option network 'vlan10'
option key 'schwachespasswort'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca955x_wmac'
option htmode 'HT20'
option disabled '1'

config wifi-iface 'default_radio1'
option device 'radio1'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'vlan20'
option network 'vlan20'
option hidden '1'
option encryption 'psk2'
option key 'schwachespasswort'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'vlan100'
option hidden '1'
option encryption 'psk2'
option key 'schwachespasswort'
option network 'vlan100'