[solved] Problem with new image build installation

hi there
i install new openwrt image build with new machine but i have some problem with it .
with make -j1 V=sc i have this error :

make[4]: Leaving directory '/home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-5.4.41'
mkdir -p /home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-dev
make -C /home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-5.4.41 KCFLAGS="-ffile-prefix-map=/home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl=toolchain-mipsel_24kc_gcc-8.4.0_musl" HOSTCFLAGS="-O2 -I/home/urufi/openwrt/staging_dir/host/include  -Wall -Wmissing-prototypes -Wstrict-prototypes" CROSS_COMPILE="mipsel-openwrt-linux-musl-" ARCH="mips" KBUILD_HAVE_NLS=no KBUILD_BUILD_USER="" KBUILD_BUILD_HOST="" KBUILD_BUILD_TIMESTAMP="Fri May 15 02:00:32 2020" KBUILD_BUILD_VERSION="0" HOST_LOADLIBES="-L/home/urufi/openwrt/staging_dir/host/lib" KBUILD_HOSTLDLIBS="-L/home/urufi/openwrt/staging_dir/host/lib" CONFIG_SHELL="bash" V=''  cmd_syscalls= KERNELRELEASE=5.4.41 CC="mipsel-openwrt-linux-musl-gcc" HOSTCFLAGS="-O2 -I/home/urufi/openwrt/staging_dir/host/include " INSTALL_HDR_PATH="/home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-dev/" headers_install
make[4]: Entering directory '/home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-5.4.41'
  INSTALL /home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-dev//include
/bin/sh: 1: rsync: not found
make[4]: *** [Makefile:1186: headers_install] Error 127
make[4]: Leaving directory '/home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-5.4.41'
make[3]: *** [Makefile:108: /home/urufi/openwrt/build_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/linux-5.4.41/.configured] Error 2
make[3]: Leaving directory '/home/urufi/openwrt/toolchain/kernel-headers'
time: toolchain/kernel-headers/compile#1.46#0.57#4.21
make[2]: *** [toolchain/Makefile:100: toolchain/kernel-headers/compile] Error 2
make[2]: Leaving directory '/home/urufi/openwrt'
make[1]: *** [toolchain/Makefile:96: /home/urufi/openwrt/staging_dir/toolchain-mipsel_24kc_gcc-8.4.0_musl/stamp/.toolchain_compile] Error 2
make[1]: Leaving directory '/home/urufi/openwrt'
make: *** [/home/urufi/openwrt/include/toplevel.mk:220: world] Error 2

NOTE : i use debian 10 with this machine

any idea ?

That would be the first thing I would check.

I do some research about it but I didnt get any solution
And its first time I have see it with image build ,
But from error its use ... 24kc_gcc-8.4.0_.. (gcc 8.4.0)
And my debian gcc v is 8.3 (last version in debian 10 )
Is this problem if it's not same version ??

sudo apt install rsync just like @tmomas suggested

I do it in first time I see the error but its same
I distclean it and rebuild it and its same

i think its solved i have some dependencies package broken or miss so remove this package and update source and re-install it , and its work with no error

subversion g++ zlib1g-dev build-essential python python3 python3-distutils libncurses5-dev gawk gettext libssl-dev libelf-dev ecj fastjar rsync java-propose-classpath 

after that
make distclean
make clean
make download
make -j1 V=sc

theres no error with build to know

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.