[Solved] Problem compiling firmware on WSL1 [Solved]


I have always compiled my own images on Ubuntu.
Yesterday I did this (compiling from the master), but I had problems.
I am compiling ath79, without major modifications, just including some simple packages (Luci, etc.).
The generated binary files are very small, the manifest file is generated, but it is empty.
The /bin/packages/mips_24kc/ folder is also empty, contains only the name of the folders, no .ipk files.

I didn't change any settings before last compile, I just used the "git pull" command and ran make again.
No errors are displayed during the process.
Has anything changed in the last few days?

Can anyone help me how to debug this?

Thanks in advance.

Start from empty .config and reselect the device etc.


I already tried that.
I deleted the entire folder, compiled everything from scratch, same problem.

This is the content of " /bin/packages/mipsel_24kc/base/ " with my latest succesfull compile. Now this folder is "empty" , no .ipk files.


The buildbot is failing too, so may need to wait until issue is fixed


You are mixing something.
ath79 uses mips_24kc (like you first say), but your photo is about mipsel_24kc, which is totally different.

This picture is from my ramips "build_dir" (that I'm even trying to compile again now to see if the same problem will happen)

I do not have a picture from my last ath79 successfull "build_dir" anymore.

Thanks for the information.
@mbo2o and @hnyman, is this the right place to report this?


Nobody knows what goes wrong in your build, as you have provided no logs or anything specific.

You should post here the contents at least of ./scripts/diffconfig.sh so that others could see what you are actually trying to build

You should also rebuild with "make V=s" to see more closely the buildprocess error messages.

Ps. As a side note, there has been major problem with the buildbot yesterday and today, but that does not affect private buidls from sources, as you are apparently doing. But I still mention that, as there may be some effects in some situations. If you try to use the "imagebuilder", it will currently likely fail.

Hello @hnyman


The diffconfig is uploaded.

I am running the make again with the following commands:

make -i -j$(($(nproc) * 2)) V=s 2>&1 | tee build.txt | grep -i '[-^_"a-z]error[-^_.a-z]'

I will upload when it´s done.

Is this enough?

Thaks for the help.

when trying to spot issues... don't specify '-j X' or specify '-j 1'


At the first glance I do not spot anything strange.

have you already wiped the whole toolchain with "make dirclean" ?

In your build.log this error is present

fakeroot: error while starting the faked' daemon.`

Have you done a sync with master recently/


Good spotting.

Then the problem is really related to the fakeroot (which caused problems for buildbot.)

You likely need to "git pull" again to get the quite newest sources.
And then rebuild the whole toolchain after "make dirclean"

1 Like

I did this yesterday:

rm -rf openwrt && git clone -b master https://github.com/openwrt/openwrt.git && cd openwrt && ./scripts/feeds update && ./scripts/feeds install -a

ore agressive than make dirclean, write?

The issue is fixed now?
git pull, dirclean and rebuild will be enough?


yes, i built with imagebuilder successfully in the past hour

Thank tou very much for the help.

I will try.


Yeah, the issue was supposedly fixed about 33 hours ago.

Should be.


Finished the ramips compilation. Same problem as ath79.
I ran git pull on my ath79 build_dir , it saids that i´m already up to date.
Should i try make dirclean && make again? Or should i wait?


Is there anything special on your build OS?
Normal Ubuntu?

What is the Openwrt git log like? (what is the most recent commit?)


I always used Ubuntu integrated with Windows 10 and it worked until 24/08.
I haven't changed any settings since that day.


I just compiled master revision r14365-46abcb3ade for ath79/WNDR3700v2 (and v1 & 3800) with Ubuntu 20.04 running in Virtualbox in Windows 10. Quite ok. Currently running that in my router.

The generic build works ok.
It must be something specific to your build system or build config.

It might be possible that the new fakeroot plays havoc with WSL2 (that you use?), but then also other WSL2 users like @Ansuel would sooner or later run into trouble.