[Solved] Prevent openvpn from starting on reboot, but allow it to start manually

I can't figure out how to do it. If you check the "enable" checkbox in the configuration in the settings, then the tunnel start automatically after a reboot, but I don't need it. If there is no checkbox, then it does not start manually, you must first turn it on. Tell me please


Yes if the box is not checked it will not start on boot. That is what you want, right?

"Start manually" means going to the Services page and clicking Start, or running service openvpn start on the CLI.

Yes, that's right. But, alas. If the "enable" checkbox is not set for the profile (I have one), then the service will not start. It doesn't even write anything to the log. It's not convenient, but ... We'll tolerate it))

Maybe this is important: the profile is loaded from a configuration file, and not created through the web interface

Not sure if this will work, but you could try leaving the enable box checked in the luci openvpn config page, then go to system>startup and disable openvpn which, might, leave openvpn enabled but prevent it from starting at boot.


Yes that box must remain checked or OpenVPN will never start. To prevent starting on boot, use the disable button on the system--startup page.

That is not a problem but for proper OpenWrt integration you still need a "stub" UCI file at /etc/config/openvpn which points to your configuration file with option config.

Also do not have any files named *.conf in /etc/openvpn because OpenVPN will automatically and directly load those. Thus there is a convention to name OpenVPN configurations *.ovpn instead.


Wow! Thanks!! It's work ))

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.