[Solved]Port 433 binding failed


I want to use port 443 for shadowsocks server on openwrt. However the port binding failed because other service is using this port. How to know which one is using the port?


Try netstat -tunlp and look at the whole table, or pipe it through grep looking for that specific port netstat -tunlp | grep :433.

Uhttpd for the luci web interface.


Thank you guys. Yes, it is Uhttpd. I tried to Stop the service and disable it from startup. but I got the follow error:


Any advice?

If you stopped and disabled uhttpd in the startup menu, that means the web server is no longer running and therefore you won't be able to use the LuCI web interface. The error you're seeing is basically saying that the browser cannot connect to the server (which is entirely expected based on the above).

If you still want to have the web interface running, but not on 443, you need to edit the /etc/config/uhttpd config file.

Note the two lines commented below... that will disable the https (port 443) binding. Or you can just change the port.

config uhttpd 'main'
        list listen_http ''
        list listen_http '[::]:80'
        # list listen_https ''
        # list listen_https '[::]:443'
        option redirect_https '0'
        option home '/www'
        option rfc1918_filter '1'
        option max_requests '3'
        option max_connections '100'
        option cert '/etc/uhttpd.crt'
        option key '/etc/uhttpd.key'
        option cgi_prefix '/cgi-bin'
        list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
        option script_timeout '60'
        option network_timeout '30'
        option http_keepalive '20'
        option tcp_keepalive '1'
        option ubus_prefix '/ubus'

You'll also need to re-enable the uhttpd server...

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable
1 Like

Good. I commented out port 443. Thanks

you're welcome

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.