[SOLVED] Phones cannot connect to WiFi after 22.03.2 upgrade

Greetings. I recently upgraded my Linksys WRT1900ACS from 21.02.3 to 22.03.2. After the upgrade, some devices, such as Amazon Fire tables and Amazon Echo devices reconnected to the WiFi, but other devices, such as Google Pixels and Apple iPhones did not.

Any thoughts on how to troubleshoot this issue?

Start by sharing your config files:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thanks for the prompt response.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '{removed}'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        list dns '208.67.220.220'
        list dns '208.67.222.222'

config device
        option name 'wan'
        option macaddr '{removed}'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '208.67.220.220'
        list dns '208.67.222.222'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'US'
        option cell_density '0'
        option channel 'auto'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '{removed}'
        option ssid '{removed}'
        option hidden '1'
        option encryption 'sae-mixed'
        option key '{removed}'
        option wmm '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'US'
        option cell_density '0'
        option htmode 'HT40'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '{removed}'
        option ssid '{removed}'
        option hidden '1'
        option encryption 'sae-mixed'
        option key '{removed}'
        option wmm '0'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option limit '100'
        option leasetime '24h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'

try changing your encryption to standard WPA2. Some devices have issues with WPA3 and WPA2/3 mixed mode.

2 Likes

Done, but no change in behavior:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'US'
        option cell_density '0'
        option channel 'auto'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '{removed}'
        option ssid '{removed}'
        option hidden '1'
        option key '{removed}'
        option wmm '0'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'US'
        option cell_density '0'
        option htmode 'HT40'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '{removed}'
        option ssid '{removed}'
        option hidden '1'
        option key '{removed}'
        option wmm '0'
        option encryption 'psk2'

I also saw a couple of posts about disabling 802.11w Management Frame Protection under the Wireless Security section, but that did not help either.

is there anything helpful from logread cmd?

1 Like

OK. I think the cause might have been:

  • option encryption 'sae-mixed'

After saving the changes and restarting the interfaces, the phones did not connect. But I went back into the phone settings, and saw that they were giving a "bad password" message.

"But the password did not change"

On one device, I re-entered the password, and it connected. I went to another device, and clicked on the wireless network name to force it to connect, and it connected as well, without having to re-enter the password.

My guess is that the failed authentication attempts on the phones may have temporarily disabled the WiFi networks, but a reboot of the phones did not resolve the issue. It turns out that the phones just needed an additional, manual nudge.

I had tried grepping the logs for the MAC address of the phone, but nothing was appearing in the logs UNTIL I gave the phone the previously mentioned manual nudge.

root@OpenWrt:~# logread | grep "00:00:00:ab:cd:ef"
Thu Dec  1 17:54:34 2022 daemon.info hostapd: wlan0: STA d00:00:00:ab:cd:ef IEEE 802.11: authenticated
Thu Dec  1 17:54:34 2022 daemon.info hostapd: wlan0: STA d00:00:00:ab:cd:ef IEEE 802.11: associated (aid 6)
Thu Dec  1 17:54:34 2022 daemon.notice hostapd: wlan0: AP-STA-CONNECTED d00:00:00:ab:cd:ef
Thu Dec  1 17:54:34 2022 daemon.info hostapd: wlan0: STA d00:00:00:ab:cd:ef WPA: pairwise key handshake completed (RSN)
Thu Dec  1 17:54:34 2022 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.2.197 d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.2.197 d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.2.197 d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.2.197 d00:00:00:ab:cd:ef
Thu Dec  1 17:54:39 2022 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.2.197 d00:00:00:ab:cd:ef A-Phone

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.