[Solved] Permissions issue with AFPD and Shares

I was attempting to fix some permissions issues I was having with transmission and in the process I broke the permissions for AFPD. Right now I have this on my backups folder:

root@LEDE:/mnt/sda1# ls -l
drwxrwxr-x    3 john staff         4096 Feb 19 08:18 Backups

But whenever I connect to the share under user john (which I can do successfully), see the Backups folder, and try to connect to it, my macOS displays:

the operation cannot be completed because the original item for "Backups" can't be found

Anyone know what the proper permissions should be?

Can you access the directory from SSH?

Yes, logged in as root

Sounds like the problem is on the MacOS side...

I tried that and it didn't work.

I used to be able to access this share before I changed the group of Backups to "staff". Note that John is in the "staff" group. So is it a permissions chmod issue?

If you can SSH in as John and get access, it's on the MacOS side.

It seems that the MacOS side is still looking for Backups.

Otherwise, SSH in as root, check the permissions for staff and set them accordingly.

Hmm I can't ssh in as john since I don't think I gave john that permission.

I thought files/foldes have permissions, not groups. Can you explain? Backups has 775 on it drwxrwxr-x so I thought that should be enough especially if Backups is owned by john.

The users in staff...

id john
uid=1000(john) gid=100(staff) groups=100(staff),100(staff)

I just tried chmod 777 to the Backups folder and I still get the same error, so maybe it isn't a permissions issue after all...

Does anyone know what happened to this guide:


It's no longer available and I followed that when I set up my server.

Netatalk's guide...


Did you know that the wiki has a search function?


Yup, fixed it. It was an issue with /etc/afp.conf