[Solved] Password required after fresh install/hard reset - Xiaomi Router 4c

I have flashed 22.03.2 downloaded here https://openwrt.org/toh/xiaomi/xiaomi_mi_router_4c onto a Xiaomi 4c, straight away on LuCi and ssh it required a password (blank didn't work), successfully entered failsafe mode, but via SSH it also required a password. Did a hard reset, and still a blank password isn't accepted.

What else can I try?? Is my router bricked?

You sure router's running openwrt - flash was successful ?

1 Like

The default state of OpenWrt never requires a password.

Are you absolutely positive that you are connecting to the correct device? Specifically, if your computer has any other network connections active (such as wifi or another ethernet connection) it may be connecting to another device. So, turn off wifi and disconnect all physical connections from your computer to the network. Then connect via ethernet to your 4c and try again.


Oh yeh, you guys are spot on, thanks! Can't believe I missed that. I am connecting to another device.

Now I just need to figure out why this router isn't showing up on my main router's connected devices...

How is it connected? Main router LAN > openWrt WAN or openWrt LAN?

I have tried both Main Router LAN > WAN and LAN. It is showing up now and giving me an IP, but I cannot SSH or access the GUI, both just time out.

I suggest that you do what I said earlier:

1 Like

Thanks. Only issue is, I don't have easy access to a computer with an ethernet port.

Well, Ethernet is required for almost all OpenWrt devices from the default/reset state. So, the fact that you don't have access to a computer with an ethernet port is going to present a major issue.

  • Wifi is disabled by default on OpenWrt.
  • The WAN is firewalled (so you won't be able to gain access by connecting LAN > WAN and then trying to connect that way).
  • The LAN is setup with a default address of and an DHCP server, so it would be a bad idea to plug it into your main router as it would probably cause an IP address conflict and would certainly have the risk of messing things up if it ends up giving out DHCP leases.

What about a USB-ethernet adapter?

Thanks, I keep meaning to buy one. I'll have to take it to a friend's house and set it up there. Probably as a bridge with a range or something similar. My main aim is to use it as a VPN server.

Ok. It should be pretty straightforward once you are physically connected by ethernet. Make sure you get a USB adapter so you don't run into this issue again.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.