[Solved] Opkg Update: 404 WGET Returned 1 For Mt7628

As the title says, I run opkg update and I get the following:

root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/base/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/luci/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/management/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/oldpackages/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/packages/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/routing/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/telephony/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/base/Packages.gz, wget returned 1.
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/luci/Packages.gz, wget returned 1.
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/management/Packages.gz, wget returned 1.
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/oldpackages/Packages.gz, wget returned 1.
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/packages/Packages.gz, wget returned 1.
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/routing/Packages.gz, wget returned 1.
 * opkg_download: Failed to download http://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7628/packages/telephony/Packages.gz, wget returned 1.

Visiting any of the links of course leads to a 404, and if I go to the last visible page it is: https://archive.openwrt.org/barrier_breaker/14.07/ramips/

I can't seem to find dist links for MT768, can anyone point me in the right direction?

I'm running:

Linux OpenWrt 3.10.14 #7 Tue May 16 10:07:51 CST 2017 mips GNU/Linux

System Type: MT7628

BARRIER BREAKER (Barrier Breaker, unknown)

Thanks!

mt7628 support is available only from 15.05 onwards.

Why are you still on that ancient, unmaintained 14.07?

2 Likes

Supplier gave me a new file to get past a previous issue, of course I thought this was old. I think I believe I found this link: https://archive.openwrt.org/chaos_calmer/15.05.1/ramips/mt7628/

I'm hoping that this won't brick my router lol

check if your model is supported on a stable release and perform a sysupgrade

2 Likes

So I kinda went ahead and didn't check if it's supported on a stable (partially cause I don't know where) - and great news is I didn't brick my router.

The not so great news, is that it's not configured at all. There's no interfaces, no firewalls or anything really setup. Which is strange.

1 Like

google "openwrt supported". First link.

Of course I tried that, but I know this specific router model isn't recognised by OpenWRT and I figured if I filter by target type maybe I can find something knowing my router is rampips/Mt728

However visiting this:https://openwrt.org/docs/techref/targets/ramips - there doesn't seem to be a Mt728

So when I say I don't know where, it means I've attempted to google, not as your slightly condescending comment suggests.

But thank you for your time to point that out for me :slight_smile:

The solution I've found is this: https://archive.openwrt.org/releases/17.01.7/targets/ramips/mt7628/

Basically, this the latest version that supports Mt7628, it's the last version of 17. After this ramips doesn't have Mt7628 but rather Mt76x8 - which I'm not aware of the differences and whether it would work.

Also this installation didn't have any of the issues mentioned above (such as no wireless page, no firewall rules etc)

Tldr; Upadted to the latest version that supports Mt7628 , then when I did opkg update, it worked a treat!

In newer releases, MT7628 runs under the subtarget mt76x8, together with MT7688.

BTW: If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

That's handy to know, thank you for the info.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.