[SOLVED] OpenWrt reboots on my Linksys WRT1900ACS v2

Hello, I just bought a WRT1900ACS v2 and installed OpenWrt on it. It booted up and I could log in to LEDE, but after awhile (10mins) it rebooted and it ended up in a reboot loop or something and I could no longer enter LEDE or even ssh to it. No answer on pings either. So I messed around with the reset button and managed to factory reset openwrt so I could login again. It worked for awhile but again after awhile it randomly rebooted and I could no longer get in.

Anyone know whats causing this? How to fix it? I'm kind of worrying it's some hardware fault on my router.

This doesn't sound right.

  1. The 1900 supports dual firmware. Did you flash both partitions or only one?
  2. If you switch to the secondary firmware do you have the same issues?
  3. Any chance of catching anything in the logs before it reboots? logread -f
1 Like

Managed to go back to OEM firmware on both partitions and let the router stay on. It started acting up again after a few minutes so my guess it's something with the hardware and Im returning this to the store tomorrow.


If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).



i'm have one WRT1900ACS v2 and one WRT3200ACM, all router i'm install davidC502 openwrt version and all time 2 working FINE, remenber al time i install form stock FW anda user FACTORY versil for install, becouse all time i preserve a stock particion for help me.

sorry my bad inglsh.


Yes I tried davids firmware but its the same. Running for awhile then it freezes and power LED starts blinking every secomd

Will do as soon as I returned it, but im still working on it

I tried the logread -f but it doesnt output anything useful before it dies. It justs freezes after awhile and power led start blinking. After a reboot it doesnt boot but only goes back to the blinking led, The only thing to get it back up and running after that is to unplug the power cable and let it be for 15 minutes after that i boots fine again...

I think I tried leverything soon. I have reverted back to older OEM firmware on boths partitions. but still the same problem. Anyone have any ideas or can we take a qualified guess its faulty hardware? (Havent returned it yet havent had time)

When reflashing several times with stock firmware from the web UI it should be 'clean' ? uboot and no old files from earlier firmware flashed?

Yes, unless you selected to keep old settings, after flashing all should be brand new.

Since the OEM firmware has the same behavior, you most likely hit a faulty unit. Better return it for a new one.

Thats just unlucky. Thanks for the help though

1 Like

Hi did you use the PSU that came with it? I have had routers that mess up like this when you use a wallwort that did not have the rite ampearage.

funny you mention it. Because I'm testing another PSU at the moment. But yes, I used the orginal linksys I have also checked on the label its correct volt and amp. But at the moment im trying another one same V a little less A but its running at the moment, we will see for how long. Could it possible be a faulty PSU.. fingers crossed :open_mouth:

update: Nope! Same issue again. Gaah........ :expressionless:

But at the moment im trying another one same V a little less A

Don't do that. That's not how electronics work, at least not for long. (All things being equal, if the power supply has the ability to provide more amperage than needed, fine.) Doubly so if testing for bad hardware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.