[SOLVED] OpenWrt on TP-Link TL-WR841N/ND v8 - some newbie questions

I've installed openWRT on TP-Link TL-WR841N/ND v8 (thanks a lot, great system), but I'm a newbie and have some questions.
I'm wanting to use this as a dumb AP, so I've tried to follow the instructions at https://openwrt.org/docs/guide-user/network/wifi/dumbap.
The router is working mostly as expected, but I can't see it listed on my main router, tough it is listed at another AP I have connected to the network.
The firmware installed: OpenWrt Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release (git-15.363.78009-956be55)
I access the router via the static IP that I've set (, which is outside the main routers dhcp range), and it is listed at that address on the second AP, so I can't see why it shouldn't be listed as such on the main router (Huawei HG658).
I suppose it's remotely possible it's some kind of bug with the main router but there's nothing else playing up on it, now or previously. All the other connected devices list ok at the relevant webpage.
Only other issue seems to be there's an active dhcpv6 lease (on the OpenWrt TP-Link interface) for the computer I'm using to access the router - if I had actually set the router up as a dumb ap shouldn't there be no such leases?
Where should I look in the router pages to confirm that it's a dumbap, if I had set that up correctly.
Any hints?
Thanks very much

The check box only disables IPv4 DHCP. You also have to go to the IPv6 tab to disable the IPv6 DHCP server.

Statically addressed devices will not show up as DHCP leases on the DHCP server (main router). The way I run this is to make the dumb APs DHCP clients and give them hostnames, which will show up on the main router. Also if main router is properly configured, you can go to hostname.lan to access the dumb AP's configuration.

Disabling the IPv6 DHCP server, do I use Network->interfaces->Lan:edit,DHCP Server->IPv6 Settings?
Giving the dumb APs hostnames - for my OpenWrt, do I do that under Network->hostname, or should I be doing this on the main router?
Also, should I really be putting questions like this on the https://forum.openwrt.org site (I only just noticed that site!).
Thanks again.


Network > Hostnames on the main router

LEDE and OpenWrt merged in January, so questions here are fine.

Thanks everyone, still not quite there.
Under Network->interfaces->Lan:edit->Advanced settings tab:
should I untick 'Use builtin IPv6-management'? (it's currently ticked)
shuold I untick 'Bring up on boot' (it's currently ticked)

I still can't see the device (MAC or it's ip) anywhere in my main router, so I'm not able to name it there.

My /etc/config/network file (my wifi is turned off) looks like the following

config wifi-device  radio0

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix '...'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask ''
        option ip6assign '60'
        option ipaddr ''

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'

Kind regards

Under the lan interface, change from 'static' to 'dhcp' and add an option hostname. This is also available in the GUI by network->interfaces->edit button for lan. Change the protocol to DHCP client then fill out the hostname box. The overall hostname in the System config is not automatically used for DHCP.

You can then add a reservation in the main router to give the AP a consistent IP when it makes its DHCP request. This is really only necessary if you must refer to the AP by IP address instead of name, such as for setting up a GRE tunnel.

1 Like

Thank you. Done. How do I mark this as solved?

You can mark the thread solved by clicking on the pencil icon on the right of the thread title and edit.

Click the blue checkmark below the title to save.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.