[Solved] OpenWrt on MT7621/MT7615N devices with 5GHz problems

The WiFi on the 2.4 GHz is quite good and when using a snapshot release where arinc9 patches/PR are in effect, ethernet routing is excellent.

Only the 5 GHz WiFi is a dud. :frowning:

1 Like

Hi, I have a TP-Link Archer C6 v3 (or v3.2 I don't understand the difference since they are the same board) which is the model identical to the Archer A6 v3.
Currently with the last snapshot (r21399-644175c29c) 5GHz seems stable with 1 station, pretty stable with 2 and no really stable with more than 2 stations.
If someone needs/wants to test something on this particular model that can improve 5GHz stability please let me know, I really want 5GHz to work just fine as 2.4GHz does.

Some new WiFi issue findings from my side:

I run a dir-1960 (mt7615), currently as access point + an additional x86 router, both 22.03.2.

  • I never had any WiFi issues on 5 Ghz before on the 1960
  • 1 IoT device had issues on 2.4 back when the 1960 was still configed as router, but currently has no issues on 2.4 since it is an AP).

The access point so far was a bit neglected in setup, only had DHCP disabled, but still missed some DNS settings (though no device had issues)
A few days ago, I had taken care of proper AP setup, and also added an additional guest network to the AP according to https://openwrt.org/docs/guide-user/network/wifi/guestwifi/guestwifi_dumbap
(Firewall settings to restrict guests not yet added)

interestingly, since that change, an airplay2 receiver on 5 GHz WiFi on the regular LAN still works, but now looses WiFi connection several times per day. All other 5 GHz devices have no issues. (the guest net config is only for 2.4 GHz)

Resetting the airplay2 receiver and reconnecting its 5GHz Wifi does not help to get airplay2 back online. To fix it for a few hours, I have to reboot/restart the access point. On 2 occasions I even had to additionally reboot the separate x86 OpenWRT router, before the airplay2 receiver went back online again.

I have not yet touched/undone the additional (but otherwise working) guest network config from the AP so far.

Instead, by coincidence I have seen thread Belkin RT3200: iPhone 11 frequently loses connectivity - #13 by darksky a few days ago, discussing „dtim“.

I currently tried
option dtim_period '1' (changed from default 2) + still keep beacon_int '100' (default)

Surprisingly this seems to fix the disconnection issue of the airplay2 receiver from appearing for the last 3 days. No more issues have appeared yet.

I am still clueless, why extending the network config for 2.4 GHz on the AP suddenly causes 5GHz WiFi disconnect issues on 1 device and why dtim comes to rescue.

…Just wanted to share this interesting finding. Likely there is something else buggy with mt7615, but interesting to see how the problem started after a non WiFi related config change and that dtim seems to help here.
(Not sure, if I missed dtim/beacon-related arguments in this thread)

1 Like

Not the WiFi access point fix, but I have now identified the additional reason, why I had to additionally reboot the separate router on so far 3 occasions.

22.03.2 seems to have a randomly crashing DHCP service.
When it happens, previously connected devices (that already got an IP) continue working, while newly connected devices though establishing a Wifi connection refuse to transfer anything (as they dont seem to get an IP address). So if not checking thourpughly, it may look like only a single device is affected.

Today it was concidence: I first noticed that other issue on my PC via LAN cable.
On previous occasions it sinply went unnoticed that LAN equipment or other reconnecting devices would suffer as well.

others seem to have noticed the DHCP issue as well:

1 Like

Thanks for the updates Pico.

As for myself,
Still encountering snail pace performance with 5 GHz WiFi using snapshots.
Gave up on using 5 GHz.

1 Like

@Warlock Just ordered a DIR-2640, and saw this thread...

From a quick glance, 5ghz is not working properly even on latest master?

At least as of snapshot dated December 12, 2022.

Error messages are not displayed
The 5 GHz WiFi is slow, to the point I don't bother using it.

e.g. Using a budget android phone, with the 2.4GHz WiFi, a sample news webpage loaded completely in 15 seconds. The 5 GHz WiFi still had not opened after a minute.

EDIT: Using the lower channels 36, 40, 44, 48 makes the 5 GHz WiFi tolerable, unlike upper channels such as 149.

1 Like

For those willing to experiment,
Stable 22.03.3 is available for MT7621 routers.
Download available from ̶F̶i̶r̶m̶w̶a̶r̶e̶ ̶S̶e̶l̶e̶c̶t̶o̶r̶ or the original download Releases page.

EDIT: Not sure what happened but I was unable to login to my DIR-878 via LuCI after I updated with firmware using Firmware Selector. Wanted the irqbalance, AdBlock and LuCI for AdBlock packages included. Possibly temporary glitch?
No problems using firmware downloaded traditional method/download server, then installing packages manually using opkg.

EDIT2: Tested Firmware Selector again but with DIR-882 this time, same problem.
No problem using download/firmware from original download server.

1 Like

5GHz didn't work well at all for me either until I found the right combo of settings.

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option country 'US'
        option band '5g'
        option htmode 'VHT80'
        option channel 'auto'
        option txpower 'auto'

When I didn't set country it definitely was broken and wouldn't connect. Default is to not set it...

1 Like

I doubt that setting the country is source of the problem
Majority, if not all of the users do set the country settings by habit.

I set the country settings in three different D-Link router models and it had no effect.

As for the channel width,
The default is 80 MHz.

I found out that if you set channel bandwidth to 80 mhz and channel to auto and get DFS radar(which you will if you live in area with a alot of wifis) openwrt will shut down the wifi altogether. Openwrt will insist on using the upper DFS channels. I've been using channel 44 and 40 mhz BW because of that. I am using 22.03.2 and quite frankly, it feels just as buggy as as the early 22.03 rc releases I tested back then. I am mostly using eth as much as the ports allow me to these days together with piVPN(which is awesome, love it). As soon as I add more 5ghz devices it starts dropping connections and other weird connection issues happen. Cannot wait to disassembly this device and sink the PCB to baltic sea to corrode. Unfortunatelly finding a reasonably priced replacement is difficult as usual. Nighthawk R8500 and R7500(v1 unfortunatelly) are the only ones I have seen used 30-40 euro a pop.

1 Like

I have a couple of mt7621 devices and have no issues with 5ghz wlan. I use to have for devices conected at the same time. 2 androids + 2 laptops

all of them get between 100 and 300 mbps wan upload download tests (300 is limit in my wan)

I was on 21.02 and now on 22.03 since it was released
My devices are zbt we1326 v5 256Mb ram and v1 512Mb ram with same results

1 Like

The ZBT WE1326 wireless chips are not MT7615.
The two listed are MT7612EN and MT7603EN.

My apologies :sweat_smile:

No worries.
Many look only at MT7621 and overlook the WiFi chip(s).
Mentioned as to not confuse others browsing this topic. :slight_smile:


Does someone know how slow it 5Ghz recently comparing with 2.4 GHz?
I needed to buy a new phone, and Android 13 doesn't support L2TP/IPSec VPN anymore which is the only one possibility on stock firmware. So I needed to switch back to OpenWRT after a time, in order to reach my network from my phone (maybe with use of Wireguard). I didn't plan to buy a new router, but I do not want to flash a problematic or slow image. Is it safe not to flash snapshots? Or shall I wait for
a new stable release and hope that 5Ghz bug will be solved? Thank you.

Can be 3x slower than 2.4 GHz.

If your router is a D-Link DIR-878, DIR-882, DIR-2640... series,
The recovery process is simple and quick, so no problems using snapshots. Use the Firmware selector to include necessities. e.g. LuCI, irqbalance.
Just make sure to have a firmware that you know works to your liking as a backup/standby.
e.g. Stable 22.03.3 release.

Would not count on it.
The 5 GHz problem has been present for months/years.

If you already have a router (MT7621/MT7615), you can avoid the headache altogether by disabling the router's Wifi and purchasing/using a separate access point.

Thank you for your answer. I thought anyhow that arinc9's patches will solve this issue permanently, that's why I was looking for snapshots. Maybe with turning on HW flood offloading function.

Anyhow the slow output of 5Ghz is somehow hardcapped? I mean I have an ISP with DL speed 500 Mbit/sec (far lower then the output of the router). Will this be affected as well, or the issue only happens to ones that have higher DL speed from the provider.
I know I should try it myself, just I'm interested with that.

Thank you.

The radio is correct discover on startup??
On Netgear r6220 is a lottery with newest version.

? arinc9's patches don't deal with WiFi.