[Solved] OpenWrt on MT7621/MT7615N devices with 5GHz problems

Something doesn't add up. I have a DIR-882 A1 that I've been daily driving for a little over an year now, always on snapshot build (updated monthly) and I never experienced this problem. In fact, I've just discovered this topic through the link added to DIR-882 ToH on the wiki, otherwise I wouldn't know.

The list of 5 GHz clients connected to the DIR-882 includes a laptop with an Intel 9260NGW card, two phones (Xperia X, Galaxy A71) and a Blu-ray player (Sony BDP-S6700 -- no ac through, just 802.11abgn).

All Wi-Fi settings for the 5 GHz network are the default ones apart from enabling WPA2-PSK/WPA3-SAE Mixed Mode and 802.11r Fast Transition between the 2.4 GHz and 5 GHz SSIDs. Here's the UCI config, if it helps debugging what's wrong (SSID and password were removed):

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio0.htmode='HT40'
wireless.radio0.channel='3'
wireless.radio0.cell_density='0'
wireless.radio0.noscan='1'
wireless.radio0.disabled='0'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid=******
wireless.default_radio0.key=******
wireless.default_radio0.ieee80211r='1'
wireless.default_radio0.mobility_domain='8012'
wireless.default_radio0.ft_over_ds='1'
wireless.default_radio0.ft_psk_generate_local='1'
wireless.default_radio0.encryption='sae-mixed'
wireless.default_radio0.ieee80211w='1'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='36'
wireless.radio1.hwmode='11a'
wireless.radio1.path='1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
wireless.radio1.htmode='VHT80'
wireless.radio1.cell_density='0'
wireless.radio1.noscan='1'
wireless.radio1.disabled='0'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid=******
wireless.default_radio1.key=******
wireless.default_radio1.ieee80211r='1'
wireless.default_radio1.mobility_domain='8012'
wireless.default_radio1.ft_over_ds='1'
wireless.default_radio1.ft_psk_generate_local='1'
wireless.default_radio1.encryption='sae-mixed'
wireless.default_radio1.ieee80211w='1'