[solved]OpenWrt on EEEPCwith only one wired NIC. How to config to connect to Internet?

Just solved the NIC driver issue on my EEEPC with openwrt 18.06.1/generic. Special thanks to mk24!

Next question is how to configure to connect to Internet? My EEEPC only has 1 wired NIC. Please provide some tutorial link if possible.

Thanks in advance!


Do you want to use it as a router or just a LAN-client?
What about wireless interface?

use as secondary router. It is a LAN-client of the primary router.

There is no wireless interface.


uci set dhcp.lan="dhcp"
uci set dhcp.lan.interface="lan"
uci set dhcp.lan.ignore="1"
uci commit dhcp
service dnsmasq restart

uci -q delete firewall.@zone[0].network
uci add_list firewall.@zone[0].network="lan"
uci add_list firewall.@zone[0].network="lan6"
uci commit firewall
service firewall restart

uci -q delete network.wan
uci -q delete network.wan6
uci -q delete network.lan
uci set network.lan="interface"
uci set network.lan.type="bridge"
uci set network.lan.ifname="eth0"
uci set network.lan.proto="dhcp"
uci -q delete network.lan6
uci set network.lan6="interface"
uci set network.lan6.ifname="@lan"
uci set network.lan6.proto="dhcpv6"
uci commit network
service network restart

Thank you. Will try tomorrow and see what happen.

I modified etc/config/network
eth0 is is static as my primary router is

My modem and primary router are combined as one piece.

Here is my network config:

A cable modem with built in primary router provide the internet. So there are no “wan” port on the primary router. Primary router has IP and acts as DHCP server.

A mini old laptop EEEPC with installed openwrt will be my secondary router. It only has one wired NIC port. No wireless. Connect it’s wired NIC port to one of the primary router’s “lan” ports. And changed its IP to static Disable its DHCP as there already has one DHCP server from the primary router. From Luci Networks/Diagnostic/ping, bad connection. Also tried following on CLI of the EEEPC:
nslookup google.com //showing some IP, seems some connection.
nslookup google.com // showing bad connection.
ping //showing some IP, seems some connection.
ping google.com //showing bad connection.

First step I want to let this EEEPC can connect to internet. But how?

Haven’t try vgaetera’s suggestion. Want to clarify first.


It would be a bit troublesome to use as a router other than VPN-router/gateway.

Currently there is only “lan” linked to eth0 (the mini pc only has one NIC).

Do I need to add a “wan” which also linked to eth0? Cannot connect to internet without a “wan”?


You can't build an orthodox router with one NIC only.
It would require either iptables/sysctl tricks or utilizing VLANs to mimic standard behavior.
About that topic I have theoretical knowledge only, so all the testing and troubleshooting would be on yourself.

Thanks. Seems I need to do more research.

To use as a LAN client with a static IP, you also have to set up the gateway and DNS options on the LAN network. The gateway is the main router IP. The DNS server can be the main router or a third party like With these settings OpenWrt can reach the Internet. You don't need a WAN network since it isn't actually routing anything.

As others mentioned, the most likely use case for such a machine is as a VPN client or server giving other computers on your LAN access to a VPN.

1 Like

Thanks mk24.

I knew what you said.

config the eth0 as static IP eg. (the primary router is
gateway IP using the primary router's IP
DNS is also udsing192.168.0.1

In the future, other LAN client (my laptop A) will configured as static IP eg. with its gateway IP configured as which is my EEEPC(openwrt) IP. So my laptop A will go to EEEPC(openwrt) first, then EEEPC will go to primary router to connect to internet.

The problem now is EEEPC(openwrt) fail to connect to internet.

Any idea?


ip a; ip r; cat /tmp/resolv.conf.auto

See comments in Can we add usb-RJ45 adaptor to add another Ethernet port on a pc using openwrt x86?

But what use would you give to that notebook with OpenWRT?

to break the limit of GFW

Got it -- took me a minute with the acronym and why you didn't use more than those letters, but I much better understand the situation now.

(Depending on which EEPC you have, it may be a better choice with an Ethernet dongle than a cheap wireless router as your application doesn’t require wireless and benefits from CPU power)

Another option may be one of the inexpensive routers supported by OpenWrt, with many suggestions and opinions in the long thread linked below. I don't know what prices / availability there are where you are, but many are not much more expensive than a USB Ethernet dongle here in the US (US$20 or less).

finally solved the problem.

config the interface eth0


Before, I used my primary router IP as DNS IP which not allowing me connecting to internet. With new setting, it is working.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.