[Solved] OpenWrt on D-Link DIR-810L A1

Well, hello there!

I've tryed using ./ncc_att_hwid -f openwrt-18.06.4-ramips-mt7620-dir-810l-squashfs-sysupgrade.bin -m "DIR-810L" -H "A1" -r "WW" -c "1.0" -F "1.02b22" -a. a bit modified then given on guide but that's because of different version of hardware (A1) and software (18.06.4)
I get -bash: ./ncc_att_hwid: cannot execute binary file: Exec format error and ./ncc_att_hwid: 1: ./ncc_att_hwid: Syntax error: "(" unexpected depending on "user" (Syntax one is with sudo and other one is without).

I need help getting this last step given...

@vlatko019, welcome to the community!

Did you set the file as executable by running chmod +x ncc_att_hwid ?

My guess would be that the procedure described on the devicepage is only applicable to the B1 version.

Have you tried TFTP already?

1 Like

No, I did not. All I did was command given on guide.

I tryed only what's writen on guide.

OK, what happened when you tried it?

Literaly nothing

Was extra parameter plus I had no libraries. Problem is solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.