[Solved] OpenWrt installation on TP-Link Archer C2600 v1.1

I just purchased a TP-Link AC2600 which will replace my Archer C7.
Been running OpenWrt/Lede for years on the C7 but it was time for a small upgrade.

If I check the latest (stable) build for the AC2600 I have 3 options to download:

  • tplink_c2600-initramfs-uImage
  • tplink_c2600-squashfs-factory.bin
  • tplink_c2600-squashfs-sysupgrade.bin'

I know the difference between the two squashfs versions (factory - sysupgrade) but what about the initramfs-uImage? Can some one shed a light on this what this version does and if I need it?

You only need factory + sysupgrade image.
The initramfs is not needed for OpenWrt installtion. Just ignore it.

1 Like

Ok, great. Thanks.
Flashed factory image without problems!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

BTW: Some more information on initramfs: https://openwrt.org/docs/techref/image.format#initramfs

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.