[SOLVED] OpenWrt 18.06.1 - luci-app-openvpn

Hello there, i am new here. Just installed the latest openwrt on my new linksys wrt3200acm.
All works pretty fine. But now i tried to configure the router as an openvpn client.
luci-app-openvpn installation was without any errors. But on the webinterface i cannot add new configurations. when i try and push the add button i come to the next page but there are no config options, they are greyed out. i can push save but nothing happend.

is it possible that the luci-app-openvpn got a problem in that version ?

thank you very much.

root@OpenWrt:~# opkg list-installed | grep luci
liblucihttp - 2018-05-18-cb119ded-1
liblucihttp-lua - 2018-05-18-cb119ded-1
luci - git-18.247.71242-9541751-1
luci-app-firewall - git-18.247.71242-9541751-1
luci-app-openvpn - git-18.247.71242-9541751-1
luci-base - git-18.247.71242-9541751-1
luci-lib-ip - git-18.247.71242-9541751-1
luci-lib-jsonc - git-18.247.71242-9541751-1
luci-lib-nixio - git-18.247.71242-9541751-1
luci-mod-admin-full - git-18.247.71242-9541751-1
luci-proto-ipv6 - git-18.247.71242-9541751-1
luci-proto-ppp - git-18.247.71242-9541751-1
luci-ssl - git-18.247.71242-9541751-1
luci-theme-bootstrap - git-18.247.71242-9541751-1

root@OpenWrt:~# opkg list-installed | grep openvpn
luci-app-openvpn - git-18.247.71242-9541751-1
openvpn-easy-rsa - 3.0.1-1
openvpn-openssl - 2.4.5-4

root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.63 #0 SMP Wed Aug 15 20:42:39 2018 armv7l GNU/Linux

That package should be OK to start/stop VPN-instance.
But configuring OpenVPN is much more reliable in CLI over SSH.


hmm. Okay i will configure it via cli but when a package gives a gui option to add a configuration and that doesn't work, i think it works not as designed. maybe there is something broken.

thank you.

That bug regarding adding new openvpn instances via LuCI GUI has been fixed in trunk (not in 18.06 tree yet!) with this commit https://github.com/openwrt/luci/pull/2154/commits/c2656a722097a7b4004d2da9c223b347cfa1a4af

1 Like

Thank you for that information. I just set it up successfully via command line.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.