[solved] OpenVPN, tcp 443, Webserver


I had running a nginx webserver on Now Lede is doing a port forward of wan:80 and wan:443 to this IP. nginx on returns 443 on accesing the port 80. So the webserver is handling 443 ssl. I do have 4 redirect running in nginx. So by the destination host name I redirect the trafic like 192.168.1.x.

This is working without any problem. All host address are getting to the right destination.

No I setup OpenVPN on port tcp 443. I added the option "port-share 443" in the /etc/init.d/openvpn file. And I disabled the port forward of 443 in the firewall.

Now I can access OpenVPN on tcp 443 but not all nginx redirections. It looks like the option "port-share" is forwarding the request by the source IP and not the original host name. So nginx does redirect everytime to the same website - also with different host names.

How to fix this?

have you rebooted every system after the changes? there might be caching involved

You are basically asking OpenVPN to do source-NAT on the redirection, and I am not sure it can do that...

I just tried again with my setup and it is working fine!
I added the line like here to /etc/init.d/openvpn:

And removed the port forward of 443 in the firewall.
Everything working as expected.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.