[solved] Odhcpd warning every ~2 mins - daemon.warn odhcpd: DHCPV6 SOLICIT IA_NA

Hi there,

I set up a new router here with recent LEDE and everything works as expected.
Only some warnings in the logs are annoying me. Mostly because I can't figure out
what they are about.

The log reads

 Mon Nov  6 12:14:22 2017 daemon.warn odhcpd[11272]: DHCPV6 SOLICIT IA_NA from 00030001f0795937acd0 on br-lan: ok fda3:6e4d:4b92:10::29e/128 
 Mon Nov  6 12:16:17 2017 daemon.warn odhcpd[11272]: DHCPV6 SOLICIT IA_NA from 00030001f0795937acd0 on br-lan: ok fda3:6e4d:4b92:10::29e/128 
 Mon Nov  6 12:18:14 2017 daemon.warn odhcpd[11272]: DHCPV6 SOLICIT IA_NA from 00030001f0795937acd0 on br-lan: ok fda3:6e4d:4b92:10::29e/128

I already found this troubleshooting guide in the openwrt wiki but it suggests to disable dhcpv6, not an option for me.

the part in my /etc/config/dhcp is

config dhcp 'lan'
    option interface 'lan'
    option start '150'
    option limit '254'
    option leasetime '12h'
    option dhcpv6 'server'
    option ra 'server'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'

I captured the packages with tcpdump/wireshark

Screenshot_20171106_123531

Does anybody know what is happening there and how to get rid of it?

Thanks
Moritz

Why is that not an option?

Yes, and you can get rid of it; but you said it's not an option...you need to disable DHCPv6 and RA on your LAN. Specifically RA.

Yes, and it's also noted in an old bug report flagged as 'worksforme,' which is why you find that exact information on the Wiki: https://dev.openwrt.org/ticket/17715

The clients on your LAN are seeking IPv6 servers, IPs, etc. You could disable their IPv6 instead.

See: https://wiki.openwrt.org/doc/techref/odhcpd for the meaning of your 2 settings.

Make sure you set them to 'disabled' to get the desired affect.

Thanks for your reply.

Because I want to use also ipv6 addresses in my network. With most of the clients it seems to work. Just this client is not.

When I disable ra and dhcpv6 dynamic ipv6 addresses will not be available in my network, correct?

Its possible to shut up logging

config odhcpd 'odhcpd'
option loglevel '4'

loglevel is bit mask and consists of bits, each of them enable specific messages like error, warning, debug
dont remeber exactly. 4 means error only, 0 means nothing

So, the issue is with a client.

Incorrect, you CAN disable them.

Why?

Because IPv6 issues Link-local IPs to every interface where it's enabled. Simply use Link-Local IPs for your IPv6 connectivity. See: https://en.wikipedia.org/wiki/Link-local_address#IPv6

That could be but then there is no name resolution anymore. So not an realistic option.

Finally I solved my issue:

The problem was a computer with an integrated ASMB8-iKVM management console. Even with recent firmware it was not able to issue a correct DHCPv6 request. Therefore the solution was to disable IPv6 on the client.

1 Like

You actually can set the loglevel of odhcpd to something lower than 4 (warning) to suppress the warning messeages and everything above. You are just missing the option in your config file:

config odhcpd 'odhcpd'
 	option maindhcp '0'
 	option leasefile '/tmp/hosts/odhcpd'
 	option leasetrigger '/usr/sbin/odhcpd-update'
 	option loglevel '4'

set it to

option loglevel '3'

and the messages you describe will be gone.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.