Hello all
Im currently switching my NWA50AX WiFi AP to OpenWRT to get more freedom, like SNMP for monitoring which the old FW do not support in thier "small business" version...
My Setup looks the following:
- Main Firewall is OPNsense
- VLANs
- 69 Management LAN(PVID)
- 500 Private WiFi
- 501 Guest WiFi
- NWA50AX with OpenWRT 22.03.5
Steps that i have done:
I configured "br-lan" as DHCP Client so that it can get an IP Address in the PVID VLAN 69 via the DHCP Server running on OPNsense. So that i can reach it in my local network for configuration.
Created a VLANq device with VLAN 500 called "br-lan.500" with a Interface called "VLAN500" which is assigned to my Test SSID.
What do i want archive:
- Dumb AP
- No DHCP, Routing e.g. from the AP, everything should still only be on L2 (Worked without issues with the original FW)
- Do the same to my second AP if i get this working finally
Problem:
However still after the configuration i have done when i want to connect to the SSID im not not getting an IP Address from my OPNsense Firewall, also setting a static IP is not working, i cannot see any traffic from the AP to my OPNsense Firewall, in this VLAN from my AP. Im right now really out of ideas, even from my tests creating a new bridge with eth0 didn't worked either. Do you have any ideas?
Configs:
/etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option packet_steering '1'
option ula_prefix 'fdcb:3046:49c7::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan'
config interface 'lan'
option proto 'dhcp'
option device 'br-lan'
config device
option name 'eth0'
option mtu '1500'
config device
option type '8021q'
option ifname 'br-lan'
option vid '500'
option name 'br-lan.500'
config interface 'VLAN500'
option device 'br-lan.500'
option proto 'none'
/etc/network/wireless (OpenWRT SSID is disabled, only my test SSID is enabled)
config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option channel '1'
option band '2g'
option htmode 'HE20'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
option disabled '1'
config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
option channel '36'
option band '5g'
option htmode 'HE80'
option disabled '1'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-iface 'wifinet2'
option device 'radio0'
option mode 'ap'
option ssid 'Test'
option encryption 'sae'
option key 'Uhhh no sorry :)'
option network 'VLAN500'
Hope someone can help me out, thanks alr!