[SOLVED] Not getting a public IP from Virgin Media hub after restoring OpenWRT backup

Hi all, I'm using OpenWrt 22.03.5 r20134-5f15225c1e on a generic x86-64 device, and I have a Virgin Media UK Hub 5x box provided by my ISP.

I had managed to set the VM box in bridge mode, and was using OpenWRT as my main (and only) router for my home network. Insert here some shenanigans with OWRT settings and my router stopped connecting to the internet. Not a problem, I thought, I'll just re-install OWRT and restore the backup I took right before starting messing around.

So that's what I did and, to my surprise, OpenWRT had stopped getting the public IP address from the VM box. No matter how many times I restarted both the VM box and OWRT, or how many times I reset the VM box to factory settings and enabled bridge mode again.

The fun bits?

  1. Connecting my PC to the VM box in bridge mode, my PC was getting the public IP from the box, and

  2. Resetting the VM box and leaving it as DHCP server, and now OpenWRT is getting an IP from the box (192.168.0.76), and will happily connect to the network.

  3. I tried a 1 week old backup that I know was working, as I had to restore it a couple of days ago, but still no joy.

Option 2 is how I'm connected now to the network, which means I am double natting. I did try spoofing the MAC address, cloning that of my laptop (which was getting a public IP from the box in bridge mode), but that didn't work either.

What am I missing here? What can I try? Thank you.

Ask, and you shall receive.

Turns out, after resetting and restoring the OpenWRT backup, it didn't install the OpenVPN plugins I had installed previously. Those missing plugins were what was throwing the connection off, somehow.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.