[Solved] No wireless with no WAN connection

I've probably got the dumbest question ever, one I've not been able to solve for a week...

When my OpenWRT device is on and has no internet connection, it won't enable wireless.

I've enabled the checkbox "force link".

Wireless works as soon as I have a working WAN up, but if there is no "WAN" connection over my VPN the wireless is also down.

The VPN I use is a WireGuard VPN to my home network, it worked fine before and still works on my phone... just not on my portable OpenWRT device.

My router at home also disables wireless if there is no WAN connection, with "force link" enabled.

You must install Travelmate package.

1 Like

It seems like you have a Wireless WAN. Since the client (WWAN) WiFi has to come up first, the LAN SSID cannot come online.

Try the Travelmate package, as @Willy suggested.

  • Also, be advised that Wireguard uses randomness to establish enough entropy to raise the connection. That randomness is provided by WiFi noise in most Atheros devices (especially those without a built-in Random Number Generator). So if your WiFi is down, those random numbers are never picked from the air, and your WG interface takes more time to raise.

I tried the travelmate package, but I think the wireless AP is still down while it is scanning for the "WAN" wireless and thus does not enable the "LAN" wireless.

It was working fine at home, but when I hopped on the train it obviously didn't join my home wireless network and the lan essid never came up.

I've disabled routing over the wireguard VPN for the time being as I've got another issue with it.

Aaah, I got it working as intended now!

I still had the manually added WLAN client active and had to connect through travelmate.

Wireguard seems to crash and reboot the router if routes are setup incorrectly and you try to contact an unknown/down IP in the tunnel.

Also if I press restart on the interface it reboots the entire thing, but works afterwards.

1 Like

@sfjuocekr If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)