[Solved] No web interface on 15.05.1

I am running ExtRoot on Openwrt 15.05.1 with TL-MR3420-V2 I have installed all the packages but I cant seem to access LuCi. It says "Bad Gateway". While I was installing packages I found this...

Configuring luci-app-statistics.
/usr/bin/lua: /usr/lib/lua/luci/model/uci.lua:5: module 'uci' not found:
    no field package.preload['uci']
    no file './uci.lua'
    no file '/usr/share/lua/uci.lua'
    no file '/usr/share/lua/uci/init.lua'
    no file '/usr/lib/lua/uci.lua'
    no file '/usr/lib/lua/uci/init.lua'
    no file './uci.so'
    no file '/usr/lib/lua/uci.so'
    no file '/usr/lib/lua/loadall.so'
    stack traceback:
    [C]: in function 'require'
    /usr/lib/lua/luci/model/uci.lua:5: in main chunk
    [C]: in function 'require'
    /usr/bin/stat-genconfig:19: in main chunk
    [C]: ?

So what am I missing here? Can someone tell me what do I need to do? I tried reinstalling Luci but it didnt help. Thanks

I reinstalled everything from scratch and now everything works normally.

It's recommend to update to 17.01.4...

1 Like

I know that but my device has only 4mb of flash and going for LEDE is a little problematic because the CPU starts to stay at 100% load and 1-minute load average goes to more than 10 sometimes. While on CC 15.05.1 it's normally less than 1 with maximum of 4 sometimes.

You have a couple of solutions that would like negate that, or are at least worth the try as the most up to date firmware should always be ran on WAN facing routers. I haven't followed the CC branch for a long time, but prior to LEDE and OpenWrt merging in Feb 2018 (last time I checked the git history), zero work had been done on CC for over a year, with the only commits being those done by third party maintainers for their software.

  • Solution 1:
    • Compile your own image, selecting/deselecting the desired base packages, ensuring the appropriate about of free space is left (usually ~1MB)

  • Solution 2:
    • ExtRoot (recommended solution)
      • There's specific instructions in the wiki for devices with 4MB of ROM

  • Solution 3:
    • Configure chroot's for all software that isn't included in the base compiled image.
      • This can be utilized in lieu of ExtRoot and in conjunction with Solution 1

I understand that and I am running Extroot with CC right now and I do plan to switch to a better router in the near future so when I do I will most likely go for the latest stable builds.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.