[Solved] No serial/UART connection possible / Mi Router 3G

Hi guys,

I installed openWRT according to this https://openwrt.org/toh/xiaomi/mir3g#installation_via_ssh guide. As images I used these: https://github.com/trinhpham/xiaomi-r3g-openwrt-builder/releases.

Now when I try to boot the device, it's just a solid orange LED, the blue one is flashing once while boot.
I soldered on the serial Pins and conected an USB console and tried to read the output with: screen /dev/ttyUSB0 115200.
But nothing is happening at all, when I plug in the router just the right LED of the blue ethernet port is turning permanent on and the right one of the second white ethernet port... I checked the serial conenction with a multimeter and swapped RX/TX around.

What am I missing? Can someone help me please.

If i'm right the tx gpio is also a bootcfg gpio and if you have a "strong" pullup resistor in your usb serial adaptor then your device tries to boot not from nand...
Try to connect first only the rx uart gpio, open serial connection on your desktop pc, press key 4 permanently (to enter bootloader command line) and power on your mir3g... After some seconds (>= 10) release key 4 and connect also the tx gpio. Now you should be in the u-boot command line and can also use the reset command to reboot your mir3g or do something else.
As i know, the bootcfg pins are only important on a cold reboot, so the warm reboot should work with connected tx pin.

Thank you very much for the answer! If I leave the TX clear on the Router the port LEDs wont turn on and I just see a orange light. I kept the 4 key pressed on my computer which is running the screen session and then connected the TX of the router to the RX of the console after ~15 seconds, but nothing is happening at all. When I keep pressing the 4 key the TX LED on the console should blink (?) but it's doing nothing.

EDIT: Ok problem solved.... listened to the wrong tty -.- Thank you agian for the help!

EDIT2: So now I'am stuck again with a bricked device... I used the firmware listed here: https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/
Where can I get a stable version of openWRT?

EDIT3: Even the stable image from August ist crashing:

[    4.624339] [<80549cc4>] 0x80549cc4
[    4.627807] [<80549248>] 0x80549248
[    4.631274] [<80476c4c>] 0x80476c4c
[    4.634744] [<80476c5c>] 0x80476c5c
[    4.638213] [<80476c4c>] 0x80476c4c
[    4.641680] [<8000afd8>] 0x8000afd8
[    4.645154]
[    4.646757] ubi0 error: 0x802e7530: failed to erase PEB 939, error -5
[    4.653192] ubi0: mark PEB 939 as bad

And now it crashes here:

[    0.387638] futex hash table entries: 1024 (order: 3, 32768 bytes)
[    0.393933] pinctrl core: initialized pinctrl subsystem
[    0.399756] NET: Registered protocol family 16
[    0.410003] Can't analyze schedule() prologue at 80478bc4
[    0.416100] pull PCIe RST: RALINK_RSTCTRL = 4000000
[    0.721346] release PCIe RST: RALINK_RSTCTRL = 7000000
[    0.726379] ***** Xtal 40MHz *****
[    0.729752] release PCIe RST: RALINK_RSTCTRL = 7000000

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.