[Solved] No more static IP on Ethernet

Hello
I have been using two TP-LINK WR741ND bridges for several years without a problem.
Last month I wanted to change their configuration, and since then it doesn't work as it should.
They no longer have a static address, but are in DHCP on Ethernet.
If I put a DHCP server, and I manage to connect to their new address (this is not systematic), I can try to erase their configuration with:

firstboot && reboot now

, but after a few hours it goes back to DHCP all by itself?
Has anyone ever had this problem ?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

@trendy
Here is the outputs :slight_smile:

{
        "kernel": "4.9.120",
        "hostname": "OpenWrt",
        "system": "Atheros AR9330 rev 1",
        "model": "TP-Link TL-WR741N\/ND v4",
        "board_name": "tl-wr741nd-v4",
        "release": {
                "distribution": "OpenWrt",
                "version": "18.06.1",
                "revision": "r7258-5eb055306f",
                "target": "ar71xx\/tiny",
                "description": "OpenWrt 18.06.1 r7258-5eb055306f"
        }
}
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4b:8c2d:04cf::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0 eth0.1'
        option ipaddr '192.168.1.2'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config interface 'galaxy'
        option proto 'dhcp'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        option disabled '0'
        option channel '9'
        option country 'US'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'OpenWrt_2'

config wifi-iface
        option ssid 'XXXXXXXX'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid '08:78:08:9A:95:40'
        option key 'XXXXXXXX'
        option network 'galaxy lan'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.2/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
192.168.1.0/24 dev br-lan scope link  src 192.168.1.2
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1
broadcast 192.168.1.0 dev br-lan table local scope link  src 192.168.1.2
local 192.168.1.2 dev br-lan table local scope host  src 192.168.1.2
broadcast 192.168.1.255 dev br-lan table local scope link  src 192.168.1.2
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
lrwxrwxrwx    1 root     root            16 Aug 16  2018 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Oct  8 14:12 /tmp/resolv.conf
-rw-r--r--    1 root     root             0 Oct  8 14:11 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
root@OpenWrt:~#

A few mistakes I noticed:

There is a switch configuration on vlan1 so eth0 doesn't seem right there.

SSID galaxy is assigned to galaxy interface as station, which makes sense, but also on lan which is wrong.
Remove lan from this SSID and assign it to the other wifi-iface which is access point.

1 Like

@trendy
Thanks for your help, I'm not used with router configuration ...
I removed eth0 from lan

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option ifname 'eth0.1'

and galaxy from network

config wifi-iface
        option ssid 'AximumGalaxy'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid '08:78:08:9A:95:40'
        option key 'utac0000'
        option network 'lan'

I hope I correctly understood :slight_smile:

Is there a connection with the loss of the static IP ?

It is still wrong, the network of the Galaxy SSID must be galaxy, not lan.

It's working fine, thank you :clap:
we will see if it lasts

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.