SOLVED! No internet connection with BPI-R3 OpenWRT router and Arris S33 Modem using DOCSIS 3.1

SOLVED: ISP brought a guy over and he checked the MAC address on their end to see if it matched mine. The lady that I originally called cleared my MAC address instead of putting in the new one! The tech put my MAC address in and it was solved just like that.

Hello! To preface this, I am a brand new OpenWRT user and would like to become familiar with the software, but this issue has arose first and needs a resolution.

I have setup my OpenWRT router (BPI-R3) with a DOCSIS 3.1 modem (Arris S33). My modem has established a connection to the internet through a phone call with my ISP and providing them with the MAC address of the modem. However, my OpenWRT router cannot seem to establish a connection to the internet through the modem. When connected to the router, which is connected to the modem, I can access both the modem config page and LuCI. I am not sure what to do at this point.

Here is my network topology:

Modem(Arris S33) <-> OpenWRT router (BPI-R3) <-> unmanaged switch <-> devices

To test my internet, I am current connected to one of the LAN ports on my OpenWRT router. My OpenWRT router is connected to my modem’s 2.5G Ethernet port through the router’s 1G WAN Ethernet port.

Here is my /etc/config/network:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option proto '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd84:55ac:9307::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'sfp2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '192.168.1.116'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'wan'

config device
        option name 'eth1'
        option macaddr '1a:12:53:bc:e0:75'

config device
        option name 'wan'
        option macaddr '1a:12:53:bc:e0:75'

config interface 'wan'
        option proto 'dhcp'
        option device 'br-wan'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'


I hope this helps, similar configuration, BTW.

config interface 'wan'
	option proto 'dhcp'
	option device 'eth1'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '56'
	option device 'eth1'

What's this supposed to do?

The same thing you are trying but not bridging the eth1 interface with wan. Not sure why you are doing so. Do you need to replicate the MAC address?