[Solved] No Internet connection and no acces on my Redmi AC2100

Hi! I'm total noob and there is the problem with installing luCI on my router. No internet connection and no acces in browser. But OpenWrt is up and I can put commands in terminal via SSH. I realy need help with all necessery commands with descriptions. I tried to connect device with my working router but it doesn't work (plugged into wan port as it said in tutorial). :skull_and_crossbones:

if you connect it to your existing router it should be LAN -> WAN (on redmi)

You need to make sure the old router doesn't use the same subnet as the Redmi - 192.168.1

Once connected, you must be connected to the redmi using an ethernet cable.

You could also remove the old router, and hook up the Redmi, but there's usually a delay
before the internet access comes back up again, due to DHCP renewal time out.

When up and running, execute

opkg update
opkg install luci

1 Like

You were right. My working router use adress. But I don't know how to change it.
Direct connection don't work.

in ssh run

uci set network.lan.ipaddr=''
uci set network.lan.netmask=''
uci set network.lan.proto='static'
uci commit && service network restart

The last command will terminate your ssh session, and you will (hopefully) be able to connect
at instead.

Afterwards the LAN->WAN setup between the routers will work.


Ping is ok now ))). Luci is installed. Now I can see luci web interface. Many thanks! :partying_face:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

just remember, this is suboptimal, since you're now double NATing your traffic.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.