[SOLVED] No DHCP on wireless / clearfog pro

Hi, i just upgraded from v17 to v18. Unfortunately, the config was pretty incompatible. As soon as i tried to backup the config from v17, the system was not responsible anymore (dont know what exactly happened...), so i started again from scratch with some help of the old backup.

Everything seems to work, expect my wifi. And i really do not understand why.

root@OpenWrt:/etc/config# cat network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd91:1386:4215::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth2'
	option _orig_ifname 'eth2.132'
	option _orig_bridge 'false'
	option peerdns '0'
	option proto 'dhcp'
	option macaddr '24:A4:3C:B3:B2:F6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 6 5'

config interface 'wlan'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option gateway ''
	option dns ''

root@OpenWrt:/etc/config# cat dhcp

config dhcp 'lan'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '1'
	list dhcp_option 'option:dns-server,'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '1'
	option leasefile '/var/lib/odhcpd/dhcp.leases'
	option leasetrigger '/usr/lib/unbound/odhcpd.sh'

config dhcp 'wlan'
	option dhcpv4 'server'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'wlan'
	option force '1'
	option dhcpv6 'server'
	option ra_management '1'
	option ra 'server'
	list dhcp_option 'option:dns-server,'
	option ra_default '1'

config domain
	option ip ''
	option name 'drucker'

config host
	option name 'htpc'
	option dns '1'
	option mac '70:85:c2:5d:ac:12'
	option ip ''
	option leasetime 'infinite'

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option country 'CH'
	option channel 'auto'
	option hwmode '11g'
	option htmode 'HT20'
	option path 'soc/soc:pcie/pci0000:00/0000:00:03.0/0000:02:00.0'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'xxx'
	option encryption 'psk2+ccmp'
	option key 'averysecretpassword'
	option network 'wlan0 wlan'

if someone has a clue what could go wrong or has improvements, this would be very appreciated!

It seems like my phone would connect but then it says "Retrieving ip address" and then it aborts after a couple of minutes.

Did you change the configuration manually or through Luci?

I don't really know what the problem is, but I suggest trying to hard code the wifi channel. If you configured it manually you could try resetting it to default settings and use Luci to change only what's needed for wifi to start. If you can connect to the wifi after that then change one thing at a time.

I changed it manually and through luci

What do you mean with hard code the channel?

very strange, i just updated the wifi config, now its working again... wtf
anyway, thanks

Under your config wifi-device 'xxxx' add:

option channel 'x'

Glad you got it wokring.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.