[Solved] New R7800 gets progressively unusable

Hello forum members, FYI I'm a technical user (not a dev though), but a noob to OpenWRT. This is my first day with OpenWRT in general and especially on this device.

I got the Netgear R7800 yesterday and tried the stock firmware to get a feel for its capabilities and its range. Today I installed OpenWRT 19.07 factory on it via the stock GUI. Most things worked except the 5Ghz which started to work after a reboot.

While trying some settings in Network -> Interfaces, the page suddenly wasn't reachable anymore. After a reboot other parts of LuCI were not reachable anymore. At first System -> Administration, after a factory reset the the Overview page was not reachable anymore.
Now, after another factory reset I can't even set a root PW. The browser always says site not reachable.

So my question now is: Shall I flash again and if so, which image should I use? Or am I on a completely wrong path?

EDIT: These are the only errors I could find in the syslog https://8n1.org/16645/8667

R7800 works normally quite ok with OpenWrt. Sounds like your settings are somehow screwed.

I suggest that you flash again, without saving settings. And then manually reconfigure all settings from scratch again. Do not restore form backup...

Alternative would be to login with SSH, use the command "firstboot" to reset things, reboot, and then manually reconfigure everything from scratch.

Currently probably the "master" is slightly better on 5 GHz wifi, although personally I have not had trouble with 19.07.

I have regularly published a "community build" for R7800, which contains some essential add-on packages. You might try that.

Thank you for your response!

In preparation for this buy I came across your build thread and decided initially to try the stable branch first.
I got some general questions about this process:

• Do I use the factory or the sysupgrade image if I flash 19.07 or your build?
• What image to use in case of a downgrade?
• What is the upgrade path if I use the custom images?
• Why did the factory reset not work like the "firstboot"?

Assuming that you can use the OpenWrt sysupgrade process, you would use the sysupgrade image.

You use

  • "sysupgrade" if you flash from a live OpenWrt system. E.g. sysupgrade from the
  • "factory" if you flash by using the original Netgear firmware or the built-in TFTP recovery console in the router.

I constantly jump between master and 19.07, as I build both of them. Normal sysupgrade is usually ok.

Your problems with reset sound strange, and I have no answer for that. (The "reset" in OpenWrt is a script that launches the firstboot routine, so it is possible that your reset from LuCI has not actually been done.)

Ps. my builds are pretty compatible with the relase and snapshot builds from buildbot. You can opkg install normal add-on packages, but no kernel related packages (as there is strict version checksumming).

This sounds like my experiences with Luci and HTTPS. Try unchecking direct all HTTP to HTTPS under uHTTPd section

@hnyman Thank you very much! I installed your latest build and it works well. Lots more options to play with! The 5 Ghz is not working, though.

@rawd I'm using HTTPSeverywhere which defaults to TLS. Where would I find this section?

EDIT: I played a bit with the 5 Ghz settings and gave the driver more room to decide. Now it works just fine.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

@tmomas done, thx for the hint.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.