[SOLVED] New Install No Internet Connectivity Linksys EA3500

Hi, I'm new to openwrt. I just did a fresh install and right after the install, I can't connect to the internet. The first red flag is the lights to my Internet port isn't flashing -rear . This router connects to my AT&T Uverse provided router. I've turned the power to my EA3500 on/off and did the same thing to the Uverse router. I'm not sure where to start troubleshooting. Would the result of ifconfig be a start?

br-lan    Link encap:Ethernet  HWaddr C8:D7:19:50:3A:19  
          inet addr:  Bcast:  Mask:
          inet6 addr: fd09:fdae:4e02::1/60 Scope:Global
          inet6 addr: fe80::cad7:19ff:fe50:3a19/64 Scope:Link
          RX packets:265347 errors:0 dropped:0 overruns:0 frame:0
          TX packets:166525 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:31593906 (30.1 MiB)  TX bytes:20823387 (19.8 MiB)

eth0      Link encap:Ethernet  HWaddr C8:D7:19:50:3A:19  
          RX packets:265432 errors:0 dropped:0 overruns:0 frame:0
          TX packets:167958 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:36378125 (34.6 MiB)  TX bytes:20919449 (19.9 MiB)

eth1      Link encap:Ethernet  HWaddr C8:D7:19:50:3A:1A  
          inet6 addr: fe80::cad7:19ff:fe50:3a1a/64 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:524 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:171430 (167.4 KiB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1254 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1254 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:109971 (107.3 KiB)  TX bytes:109971 (107.3 KiB)

I'm connected to the router via ethernet cable so I believe eth1 is that connection and therefore I'm assuming eth0 is the internet.


You have not provided enough information.

  • So, you had a successful flash, and can now navigate to the LuCI web GUI?
  • Did you edit any settings from the default after flashing?
  • Are you required to provide the MAC address to the ISP?
  • Are you using a CAT 5e or 6 cable?
  • Was the WAN port ever working on stock firmware (did you test it)?

(BTW, the stock photo didn't offer any detail.)

  • Yes, I had a successful flash and can navigate to LuCI web GUI.
  • No, I didn't edit any setting from the default after flashing.
    NOTE: I see an issue with the two questions above. It . would seem to assume I used a factory.bin from openwrt downoad page . I built my own from git HEAD 5beedcddc3ad2c6f92c24ce2655a84524ca26594 a couple of days ago within a Docker container. I've placed my .config file and the Dockerfile into github https://github.com/martinying/openwrt in case that contains the root of my problems. Also, I didn't do a straightforward install/flash (that's its own topic). I started from this article's google drive factory bin images https://n00bsecurityblog.wordpress.com/2018/07/24/upgrading-cisco-linksys-ea3500-to-openwrt-lede-step-by-step/ and then scp [my SNAPSHOP sysupgrade.bin] to router --> ssh to rounter --> systemupgrade [my SNAPSHOP sysupgrade.bin] . The Internet stopped working at the point of the first flash, I didn't pay attention when I initially SSH what version it is, so that could also be the starting point of my issues. I assume in upgrades, the previous configurations are preserved.
  • No, I'm not required to provide the MAC address to the ISP
  • Not sure what CAT cable I'm using, however, I assume the question is to make sure the cable is a working cable and it is, see the next answer for why.
  • Yes, the WAN port was working on the stock firmware, I've been using the router for several months so to the answer above about the CAT cable, unless the flash did something to the WAN cable, it should be a working cable. And since it's been working I'm also before without me providing the MAC to my ISP, I'm also 99% sure that's not required.
  • The purpose of the stock photo: Maybe it's more of switches vs routers but for some, all the ports look/are the same and the WAN is assumed to be the first or the last. I just wanted to demonstrated I didn't make a mistake where I have no internet because I plugged into a LAN port vs the WAN port :smile: .

You statements aren't clear whether your build, or the build from that Google Drive is currently flashed. In any case, you should inquire with the person who created the image.

  • If it's your build, please ask for this thread to be moved to the For Developers Section.
  • You can also test using the images at the downloads site to see if you continue to experience the issue. If your problem is solved with the OpenWrt build, you certainly know the issue is with the custom build.

Check the switch configuration. The switch must be properly set up to switch the WAN port over to eth1.

swconfig dev switch0 show will show if the ports are connected, and the VLAN configuration.

It is a good practice, on models that support a release build, to try running that build before asking questions here.

1 Like


I had my router turned off through the weekend and when I turned it back on yesterday it automagically started working. Unfortunately, that solution isn't very helpful. If the forum is moderated, maybe it's worth-while to delete this thread.


It is moderated, though posts are generally only deleted when they violate T&C or other policies.

Many people edit their title to start with "[SOLVED]"

When another post in the thread has a solution that you think would be valuable for others, you can also use the "Solution" checkbox at the bottom of that post.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.