[SOLVED] Network settings do not persist after reboot on 21.02.0 with a MT7621 based device


I have upgraded from version 19.x to 21.02.0 and noticed an issue with network settings being reset after a reboot.

Model: MikroTik RouterBOARD 750Gr3
Architecture: MediaTek MT7621 ver:1 eco:3
Firmware Version: OpenWrt 21.02.0 r16279-5cc0535800 / LuCI openwrt-21.02 branch git-21.231.26241-422c175
Kernel Version:5.4.143

Steps to repro:

  1. Change LAN IP from to
  2. Verify settings got applied, load in browser (also, /etc/config/network lists new IP)
  3. Reboot
  4. The router boots with the old LAN IP

All other settings like root password or hostname persist.

Is there a way to fix this?


Did you reset the settings during upgrade?
the switch from swconfig to DSA usually requires this.

Yes, I checked to do reset the settings during the upgrade. I also tried to reset it multiple times after discovering this issue, but still loosing LAN IP after reboot.

Solved. I desperately flashed the same firmware once again and once again selected to reset the settings - and now it works. Rebooted multiple times - LAN IP settings now persist.

Thanks for the hint!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.