[Solved] Network device inaccessible but network traffic passes through device

I have a main router QNAP 301W with OpenWrt snapshot build kernel 6.6.30.
I have a second device Mikrotik RB5009UG (OpenWrt snapshot kernel 6.6.30) currently configured to be used as a switch (dnsmasq, odhcpd, firewall are disabled).
RB5009 2.5G (192.168.1.250) port is connected to QNAP 10G-2 (192.168.1.1) port with LAN cable.
I have a Win11 PC (192.168.1.2).
If I connect the PC (192.168.1.2) with cable to QNAP (192.168.1.1) I can access the WAN and all network activity is OK except for the fact I cannot ping 192.168.1.250 nor access its web interface nor SSH.
If I connect the PC (192.168.1.2) with cable to RB5009 (192.168.1.250) I can access the WAN and all network activity is OK except for the fact (once again) I cannot ping 192.168.1.250 nor access its web interface nor SSH. At the same time I can ping 192.168.1.1 with this setup. I posted my question here currently using this setup.
Current network configs of both devices.
QNAP

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf1:2e2c:eb55::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports '10g-2'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	list ip6class 'wan6'

config interface 'wan'
	option device '10g-1'
	option proto 'dhcp'
	option hostname '*'

config interface 'wan6'
	option device '10g-1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option norelease '1'

config device
	option type 'bridge'
	option name 'br-vlan'
	option bridge_empty '1'
	list ports 'lan4'

config interface 'guest'
	option proto 'static'
	option device 'br-vlan'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option delegate '0'

RB5009

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5f:7715:a749::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'p1'
	list ports 'p2'
	list ports 'p3'
	list ports 'p4'
	list ports 'p5'
	list ports 'p6'
	list ports 'p7'
	list ports 'p8'
	list ports 'sfp'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.250'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config interface 'wan'
	option proto 'dhcp'
	option auto '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

config device
	option type 'bridge'
	option name 'br-vlan'
	option ipv6 '0'

config interface 'guest'
	option proto 'static'
	option device 'br-vlan'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option auto '0'

This is a recent setup and I didn't try many things.
I used the same setup for a very short time when the RB5009 was running OpenWrt with kernel 6.1 and I didn't experience any limitations to reach the device web interface / SSH.
Currently to bypass this LAN limitation I've setup a VPN in order to access the device from outside of my LAN so I can have a control over the device. This doesn't seem to work either after a reboot.

I appreciate your help.
Thanks.

What physical ports are used on each device to connect them together (the router and the switch)?

I tried almost all physical port combinations (even the SFP one on Mikrotik with this module) on both devices. Same situation.
Currently on RB5009 the cable is on Lan1 (2.5G) and on QNAP it's on one of the 10G ports (10G Lan port 2).

Try removing this from the qnap:

and also remove this from the rb5009:

Then reboot both systems and see if it works.

I've deleted on both devices and rebooted. Still the same issue. It does work with kernel 6.1 on RB5009 not touching any settings.

Update - restoring the Mikrotik RB5009 with Netinstall and updating the device to OpenWrt kernel 6.6 seems to have resolved the config issues. Obviously the issue wasn't because of any OpenWrt packages or in their configs. This unfortunately doesn't fully explain the situation.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.