[solved] Netgear wndr3700 v2 firmware does not work

i tried to install the version https://downloads.lede-project.org/releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin via openwrt sysupgrade -F but the rooter came back with a blinking power led. then i tried to install lede with the factory image via TFTP with the same result.

finally i recovered the router with ddwrt factory via TFTP. i noticed on the ddwrt page that there is a north americas version and a global version of the netgear wndr3700 v2. could it be that lede supports only the north americas version? my router was bought in Europe.

I just flashed a self-built LEDE master r4497 into my WNDR3700v2. Works ok.

To my knowledge there is no difference in v2 firmwares between North America and global. For 3700v1 there was a special -NA North America version, but not for 3700v2 or 3800.

Did you check the hash checksum of the firmware so that it is intact?

Ps. Why use "sysupgrade -F"? I don't think that there is any incompatibility between Openwrt and LEDE for 3700v1/v2/3800.

the sha256sums are ok for both sysupgrade and factory. i had to use -F because openwrt chaos calmer did not want to accept the sysupgrade with some message. would have to install openwrt back to see what the message was.

invalid image, hardware id mismatch hw: 33373031 image:33373030

could you please check your ids?

The error message implies that you have tried to flash a 3700v1 image to a 3700v2 device. If you used -F to force it, no wonder that it did not boot ok.

Are you quite sure that you have the 3700v2 image?
That 33 37 00 00 is the ID for the 3700v1 image.

I downloaded the 17.01.2 images myself, and they have correct IDs:

  • 3700v1 sysupgrade and factory images have 33 37 30 30
  • 3700v2 and 3800 sysupgrade and factory have 33 37 30 31, just as expected.

you are right. i did incidentally download the v1. sorry and thank you for your time.