[solved] Netgear GS308T loses all changes on reboot

Is there anything I can to to save changes between boot/poweron of the NetGear GS308T switch?

I have a GS308T that is recently flashed with an OpenWRT snapshot. When I make changes via SSH and then reboot, I find all changes are lost, the switch is back to original OpenWRT settings. Same after power-on.

Is there any diagnostics that I can provide to help debug?

PS For anyone that flashes this device and think that it's bricked - it's likely not. There is a tagged VLAN 100 on port 1, connect via SSH to This can be difficult if your existing router has that IP address.

I'm pretty sure you missed the last step, flashing the sysupgrade image from the (just previously flashed-) initramfs image. The initramfs image exclusively runs in RAM, all changes are lost after a reboot, you need to flash the sysupgrade image to get persistent configurations.


Where is this procedure documented? Are there special parameters to sysupgrade that must be added?

What I'm seeing is that the sysupgrade hangs or, at least does not reactivate the network. After leaving for 10 mins or more, I switched off and on then it booted into initramfs again. I tried this twice.

followed by:

# sysupgrade -n /tmp/openwrt-realtek-generic-netgear_gs308t-v1-squashfs-sysupgrade.bin

(assuming you've copied the corresponding sysupgrade image to your router's /tmp/ beforehand)


Thank-you @slh

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.