[Solved] Multicast IPTV "passthrough" Netgear R7800

I just flashed my R7800 last night. Everything works wonderful wifi and ethernet speeds are very good.

However something doesn't work on this firmware that did work on the stock firmware that keeps puzzling me.

I am using the modem/router to connect to the Internet through vdsl. They provide me with IPTV as well so I have the R7800 configured as a static IP and the modem from the ISP handles all the IPTV routing etc.

On stock firmware all i had to do was "enable igmp proxy" and it just worked. Same goes for dd-wrt where i just ticked the box "allow multicast" under the security tab and enabled IGMP snooping.
For LEDE I have followed this guide:

So igmpproxy is installed and the firewall rules have been added. However i still can't get the IPTV boxes to work. They do get an IP from the router in the normal IP range (as it' routed IPTV) but they can't bootup as they can't download their software currently.

Hope someone can help me. Thanks in advance.

Did you edit the igmpproxy config file once you installed it?
Did you specify what networks is the upstream and downstream?
Did you properly configure your firewall?

LEDE doesn't assume your downstream and upstream networks - like most consumer routers do (which don't permit editing). You you must configure the device for the proper IGMP setup.

See: https://wiki.openwrt.org/doc/howto/udp_multicast

I used this procedure with Verizon FiOS TV to install a non-Verizon router on my border (various set-top box updates are provided via IGMP).

Last build of the igmpproxy don't work. For me it stop worked after upgrade lede from 17.01.1 to 17.01.4. After downgrade to 17.01.1 it not work too. It seems to blame the recent changes in the package of igmpproxy.

Mine does, I'm running 17.01.4. This is from my firewall stats:

32 1.12 KB ACCEPT 2 * * /* !fw3: ubus:igmpproxy[instance1] rule 0 */

Here is my /etc/igmpproxy.conf:


phyint eth0.2 upstream ratelimit 0 threshold 1

phyint br-lan downstream ratelimit 0 threshold 1

You stated you downgraded, you have to re-install igmpproxy if you erase or re-flash the router.

It seems I figured out the cause of the igmpproxy glitches. It's all about the sysupgrade image. While I was trying to flash various sysupgrade images, after each flashing there were different glitches. With each flashing, I erase all configuration files, and do reconfiguration(or firstboot). Dhcp did not work, igmpproxy or udpxy did not work, on dir-825 b2 instead of 2.5 Mb of free memory, the system saw 30 Mb. All problems disappeared after the flashing factory image.
P.S. Sorry for my poor English.