[Solved] MR3420v2 Debrick

I am trying to debrick my router TpLink MR-3420 V2.2 through Serial connection. But I am getting garbled output. All the output from the start of the boot till below is garbled but a small part is properly visible.

[    0.798806] console [ttyS0] enabled
[    0.798806] console [ttyS0] enabled
[    0.806364] bootconsole [early0] disabled
[    0.806364] bootconsole [early0] disabled
[    0.821544] m25p80 spi0.0: found s25sl032p, expected m25p80
[    0.827387] m25p80 spi0.0: s25sl032p (4096 Kbytes)
[    0.833281] 5 tp-link partitions found on MTD device spi0.0
[    0.839046] Creating 5 MTD partitions on "spi0.0":
[    0.844066] 0x000000000000-0x000000020000 : "u-boot"
[    0.850869] 0x000000020000-0x00000018273c : "kernel"
[    0.857949] 0x00000018273c-0x0000003f0000 : "rootfs"
[    0.865033] mtd: device 2 (rootfs) set to be root filesystem
[    0.870937] 1 squashfs-split partitions found on MTD device rootfs
[    0.877396] 0x000000390000-0x0000003f0000 : "rootfs_data"
[    0.884920] 0x0000003f0000-0x000000400000 : "art"
[    0.891711] 0x000000020000-0x0000003f0000 : "firmware"
[    0.900177] libphy: Fixed MDIO Bus: probed
[    0.923379] libphy: ag71xx_mdio: probed
[    1.553849] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:00 [uid=004dd0                                                      42, driver=Generic PHY]
[    1.564132] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    2.193641] ag71xx-mdio.1: Found an AR934X built-in switch
[    2.246052] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[    2.255050] NET: Registered protocol family 10
[    2.264817] NET: Registered protocol family 17
[    2.269488] bridge: filtering via arp/ip/ip6tables is no longer available by                                                       default. Update your scripts to load br_netfilter if you need this.
[    2.283050] 8021q: 802.1Q VLAN Support v1.8
[    2.289340] hctosys: unable to open rtc device (rtc0)
[    2.296888] squashfs: SQUASHFS error: unable to read id index table
[    2.303734] List of all partitions:
[    2.307361] 1f00             128 mtdblock0 [    2.311503]  (driver?)
[    2.313992] 1f01            1417 mtdblock1 [    2.318133]  (driver?)
[    2.320577] 1f02            2486 mtdblock2 [    2.324722]  (driver?)
[    2.327163] 1f03             384 mtdblock3 [    2.331294]  (driver?)
[    2.333753] 1f04              64 mtdblock4 [    2.337889]  (driver?)
[    2.340333] 1f05            3904 mtdblock5 [    2.344478]  (driver?)
[    2.346913] No filesystem could mount root, tried: [    2.351779]  squashfs
[    2.354124]
[    2.355674] Kernel panic - not syncing: VFS: Unable to mount root fs on unkno                                                      wn-block(31,2)

Another thing is that, the boot process doesn't recognize any input from the laptop, at the end when it says rebooting in 1 second...
If I type something at start of the boot when the output is garbled, it stops the boot but I have no idea how to perform the flash from there since no information can be read from there. I have properly soldered the RX TX and GND to the router board. I have also debricked another router TpLink W8960N so I have no idea what is going wrong here.

Can anyone help?

1 Like

Baud rate may be different from the bootloader. Try 57600 or 115200.

Initially the bootloader sets up the serial port, during the boot the kernel reconfigures it and may be using a different baud rate.

Your rootfs in flash is corrupt, you need to reflash from the bootloader. Once you have readable output from the initial power on, when it says "Autobooting in 2 seconds" you need to type "tpl" to stop the boot. It helps to copy "tpl" to the clipboard then hit ctrl-V at the right time.


As it turns out, the baud rate was indeed 115200. I also ordered a PL2303 USB TTL adapter but it turned out to be a fake one. After juggling through the drivers to make it work properly, I finally was able to stop the boot and managed to install the firmware from serial through the Wiki instructions.

So it seems the CH30 USB TTL adapter was not compatible with TpLink TL-MR3420 V2 so it was not outputting in a proper way and no input was going through to the router. I am leaving this post here for future references.


This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.