[Solved] MR33 Flashing Issue

I am trying to install OpenWRT on a Cisco MR33 that never got connected to the internet, I have it for 1+ year already.

When I ran the ubootwrite.py script, this is the output I received:

<Meraki> '
Progress 0.2%
, 0.3kb/s
, ETA 516.0s
Progress 99.5%
, 0.3kb/s
, ETA 2.0s
Progress 99.7%
, 0.3kb/s
, ETA 1.0s
Progress 99.9%
, 0.3kb/s
, ETA 0.0s
Progress 100%
File successfully written. You should run 'crc32 80500000 00029f20' on the modem and the result must be 68cea086.
To copy from RAM to flash, unprotect flash: 'protect off all'...
Then erase flash: 'erase b0500000 +00029f20'.
Then copy from RAM to flash: 'cp.b  80500000  b0500000 00029f20 '.

I did not get an IP address nor a tftp server was listening on the device. So I ended up rebooting it.

Now at every other boot, I can telnet my way in. However the ubi commands do not work as described, seems there is only one /dev/mtd* device.

I never was able to upload the FIT uImage, and sysupgrade of the sysupgrade.bin image fails

# sysupgrade -v openwrt-ipq40xx-meraki_mr33-squashfs-sysupgrade.bin
openwrt-ipq40xx-meraki_mr33-squashfs-sysupgrade.bin is not a valid FIT image
Image check 'platform_check_image' failed.

dmesg output here: https://pastebin.com/UWMMJmZa

Possibly need

Yeah ok... where do I put that file ?

Also, there are no /dev/ubi* devices present... I'm kind of lost

Use it in place of

@mathieu : still stuck? did you use the procedure and files found here: https://drive.google.com/drive/folders/1jJa8LzYnY830v3nBZdOgAk0YQK6OdbSS (link from https://openwrt.org/toh/meraki/mr33) ?

I restarted the whole process from scratch, using the ubootwrite.py in the google drive this time, and it worked out properly! Yay!

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)