[Solved] Mount points / available space issue


I'm using v19.07.6 on a WNDR3700v4.

I've used fdisk to create a single partition (as sda1 of type linux) on a 128GB usb stick and then used mkfs.ext4 to format as ext4. The stick is obviously now completely empty.

In LuCI, when I look under System / Mount Points:

  • under the 'Mount Points' heading, dev/sda1 shows as size 119.5GB. This is as expected.

  • under 'Mounted file systems', Available is 111.57 GB / 117.62 GB and Used = 0.05% (60.02 MB) .

I don't understand why 'Available' suggests approx 6GB is used when it isn't.

Earlier I had the Ksmbd package installed and I could write approx 117.5GB to sda1 (on a Windows 10 client) despite the above.

To resolve a separate issue I've earlier removed Ksmbd and installed the samba4-server package.

Now I can only write 111.5GB to sda1 suggesting Samba4 identifies the amount of space available in a different way to Ksmbd.

Is there anything obvious I'm doing wrong? It's almost like the Available space field has a bug in it where 117 is being displayed as 111.


Linux reserves 5% of disk for use by root only. The available is the amount for "regular users" I believe


And you can change this value using "tune2fs -m".


Woo hoo!

tune2fs -m 0 /dev/sda1 worked perfectly.

Available now 117.55 GB / 117.62 GB

Thanks to you both

1 Like

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.