[Solved] Mount points apply issue

LEDE Reboot 17.01.4 r3560-79f57e422d x86_64

After opkg install block-mount(the newest), there is a option Mount Points in System menu in LuCI.
In Mount Points page, I have configured a mount point for my second strong.

Then I clicked Save & Apply,there is a error message:

/usr/lib/lua/luci/util.lua:623: Unable to establish ubus connection stack traceback: [C]: in 
function 'assert' /usr/lib/lua/luci/util.lua:623: in function 'ubus' 
/usr/lib/lua/luci/dispatcher.lua:347: in function 'dispatch' /usr/lib/lua/luci/dispatcher.lua:141: 
in function

If I access router is on it), it is also a error:

    /usr/lib/lua/luci/util.lua:623: Unable to establish ubus connection stack traceback:
	    [C]: in function 'assert'
	    /usr/lib/lua/luci/util.lua:623: in function 'ubus'
	    /usr/lib/lua/luci/dispatcher.lua:347: in function 'dispatch'
	    /usr/lib/lua/luci/dispatcher.lua:141: in function </usr/lib/lua/luci/dispatcher.lua:140>

Then I tried df, but there is noting and said df: /proc/mounts: No such file or directory.
If fdisk, it is fdisk: cannot open /proc/partitions: No such file or directory.

After reboot ,system,luci,fdisk or df would be ok, but not Mount Points.

Can you tell my what's wrong with my system and how to fix it?

It sounds like you might need some more packages/modules installed, here are two links that you can read that should help you, but for now installing these might get you started -






You also need modules for the file system of your drive (you only need the one you use) - 




ntfs-3g (for writable ntfs)

e2fsprogs (for kmod-fs-ext4)

Reboot after installation and see if you can then mount

I have installed all the packages you mentioned(In fast I just need ext4 and ntfs).
But the issue is the same, no any change.

@mike - There's a Quick Start for adding a USB drive that seemed to work for me (I documented my steps when I did it...)

Would you check it to see if there's something missing? Thanks.

1 Like

I tried

opkg update && opkg install block-mount e2fsprogs kmod-fs-ext4 kmod-usb3 kmod-usb2 kmod-usb-storage
block detect > /etc/config/fstab 
uci set fstab.@mount[0].enabled='1' && uci set fstab.@global[0].check_fs='1' && uci commit 
/sbin/block mount && service fstab enable

But the issue occurred as well.

The only problem I've ever had with mounting ext4 has been perms, you might try setting your drive to 777 just temporarily to see if that allows you to mount, then try different perms until you get as secure as you can with it still working. You also might try the guide by @richb-hanover linked above, keep in mind that will erase your drive though.

I've never been able to mount ntfs through normal Mount Points in Luci, I've always had to use this in Startup (Luci>System>Startup) and mount at boot -

ntfs-3g /dev/sda* /mnt/your_mount_point -o your,options

Also, if your device has two USB ports, try removing one drive and just mounting one drive at a time, I've had problems mounting two drives at the same time, after a setting or reboot the drives will occasionally switch, meaning if Drive A is /dev/sda1 and Drive B is /dev/sda2, a setting or reboot will sometimes reverse that making Drive A /dev/sda2 and Drive B /dev/sda1.

I actually used that guide a few months ago and it worked fine for me from what I remember, I can test it again later tonight.

ntfs-3g /dev/sdb1 /mnt/sdb1 -o big_writes works fine for me.

My issue is about the page System -> Mount Points.
I set noting in the Mount Points part in that page and just keep it original, but if I click the button Save & Apply, the issue would happen.

I might be misunderstanding, but mounted ntfs drive won't show up in Luci>System>Mount Points>Mount Points, it will show right above in Luci>System>Mount Points>Mounted File Systems.

edit - also, when a drive is first connected it will automatically get entered into Luci>System>Mount Points>Mount Points which causes problems with ntfs, you can click Delete next to the entry and then Save and Apply so your own mount point will be used, you'll probably have to do that each time you connect a ntfs drive.

@mike - I would be pleased to have someone else review those docs. I tidied up and posted a procedure that someone else gave me, and it worked for me.

But I don't know much about the entire disk-mounting process, so I can't add much expertise with advice for what other people are expecting.

Comments warmly received - or just fix the page yourself. https://openwrt.org/docs/guide-user/storage/usb-drives-quickstart - if you're following along at home.

My experience/knowledge of disk mounting is really pretty limited too, but I'll be happy to take a look and help where I can.

yeah, this is a bug in the luci and another user ran into the same issue with a different device.

in any case, if you are looking for a way to that "Save & Apply" working just apply patch in this PR:

you can do that manually, since it only requires you to change one line in /etc/config/ucitrack.

Great! It works well! Thank you!

Credits go to Daniel Dickinson. He made the patch and the github PR back in 2017.

Thankfully, @jow- has committed the change yesterday, so hitting the "Save & Apply" button won't make the openwrt device unusable anymore.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.