[Solved] Missing subsystems trying to run LEDE in a Virtualbox Virtual Machine

Have you tried typing ifconfig to see what physical NICs you have in the LEDE VM (and the NiC cards' names)???

In addition....the command is "UCI SET" NOT "UCI ADD."

ifconfig shows no NICs.

I think part of the problem is that when trying to create any files the drive shows as full, although I can't determine why that would be.

I followed the instructions below and everything worked as expected.

1 Like

I decided to better assist by just creating a VM:

VBoxManage converdd lede-17.01.4-x86-generic-combined-ext4.img.gz lede.vdi

  • I created a 32-bit Linux VM with 256 MB RAM and 2 Paravirtualized NIC Cards
  • I added lede.vdi as the HDD
  • I booted it up
  • Upon running ifconfig, I saw the following network interfaces:
    • eth0
    • eth1
    • lo
  • eth1 has an LAN IP, and is already configured for LAN
  • uci show network has entries (and I'll also note that eth0 and eth1 are reversed in UCI from the ifconfig listing, meaning in ifconfig eth1 has a LAN IP...in the UCI, eth0 is the one configured for LAN...ports are commonly labeled in reverse in LEDE, so be mindful)

Glad you got it working!
Consider editing the title and adding "[Solved]."