[Solved] Missing profile in Image Builder

I have TL-WR841N v8, currently running OpenWrt Chaos Calmer build with Image Builder with some packages included. I want to move to LEDE, but I can't build firmware by myself, because device profile is missing. I've tried adding profile by myself, like explained here, but it didn't work (profile didn't show up when using make info command, and I didn't add macro to the Makefile, because I'm not sure which makefile should I edit and how that macro should look).
I haven't found why profile of this device is missing, even though firmware is available in image files list. Should I just build LEDE from source like explained here?

Can't confirm for LEDE 17.04 release:

build@buildebian:~/build/lede-imagebuilder-17.01.4-ar71xx-generic.Linux-x86_64$ make info | grep v8
    TP-LINK TL-WR841N/ND v8
    TP-LINK TL-WR847N/ND v8

Edit: It is, however, missing for the latest snapshot, you're right there. There's a good chance it is amongst the devices not supported by latest snapshots, simply because the resulting image would not fit into the flash anymore. Those devices might return for a release build, but there's probably someone more knowledgeable than me to comment on that.

You are right. I'm an idiot and I've downloaded Image Builder for the latest snapshot, not 17.01.4. Stupid mistake.
Anyway, thank you for your help :slight_smile: