[SOLVED] Missing 5GHz radio on Dlink DAP-2680

Hello everybody
I just installed openwrt on my DAP-2680 rev A1E that I had waited for years to be supported, and in the Wireless section only 802.11bgn radio is listed! Where is the 5GHz radio? What I'm doing wrong? In the device section it says is supported and no advertisements about unsupported 5GHZ are there.
Thank you

SSH in to the router and run cat /etc/config/wireless

Redact any passwords in the option key sections.

Post the results in preformatted text, by using the icon highlighted in red...

Screenshot 2022-05-20 011120

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option htmode 'HT20'
        option country 'VE'
        option cell_density '0'
        option channel '13'
        option txpower '20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

So, when more flash space is required, a sysupgrade image can be flashed right after factory, to allow for using of all the available flash memory.

Did you Double Flash to obtain the max available flash space?

"The recovery also does not have the minimum size requirement, however we shall prefer not to have three separate images (factory padded for web-flashing, factory unpadded for recovery, sysupgrade) when the padded factory image is also accepted by the recovery (but requires double flashing to use all of the available flash space)"

Flash Layout

| --- | --- | --- |
|0x00000000|0x00040000 (256k)|bootloader|
|0x00040000|0x00010000 (64k)|bdcfg|
|0x00050000|0x00010000 (64k)|rgdb|
|0x00060000|0x00010000 (64k)|unknown|
|0x00070000|0x00ee0000 (15232k)|upgrade|
|0x00f50000|0x00020000 (128k)|langpack|
|0x00f70000|0x00070000 (448k)|captival|
|0x00fe0000|0x00010000 (64k)|certificate|
|0x00ff0000|0x00010000 (64k)|radiocfg|

Yes, I double flashed, choosing not to keep the settings (to be sure)

1 Like

SSH in to the router and run opkg list-installed | grep ath10

Post result in preformatted text.

root@OpenWrt:~# opkg list-installed | grep ath10
ath10k-board-qca99x0 - 20211216-1
ath10k-firmware-qca99x0-ct - 2020-11-08-1
kmod-ath10k-ct - 5.4.188+2021-09-22-e6a7d5b5-1

Run iw list

Post results.

root@OpenWrt:~# iw list
Wiphy phy1
        wiphy index: 1
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * outside context of a BSS
        Band 1:
                Capabilities: 0x11ef
                        RX LDPC
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (27.0 dBm)
                        * 2472 MHz [13] (27.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Supported extended features:
                * [ RRM ]: RRM
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                * [ SCAN_RANDOM_SN ]: use random sequence numbers in scans
                * [ SCAN_MIN_PREQ_CONTENT ]: use probe request with only rate IEs in scans
                * [ CAN_REPLACE_PTK0 ]: can safely replace PTK 0 when rekeying
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                * [ DEL_IBSS_STA ]: deletion of IBSS station support
                * [ MULTICAST_REGISTRATIONS ]: mgmt frame registration for multicast
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

Do a reset -

Just resetted. Still missing.

Care for a Side Track.. possible to peek at
to see if any kmod-ath10k* are relevant?

maybe i could install kmod-ath10k package, but how can I check if the other radio become available?

Do you mean the 5GHz? If so you install the package and a reload or possibly a restart, then look for a 5GHz radio.

it should be listed with the iw list command?
isn't there a command to check the periphericals like lspci in linux?

After a reboot iw list shows always a single radio

Correct if the device was present it would have shown with that command.

IDK of the other command lspci

Is that after installing the kmod-ath10k package ?

... so we're still broke ....

Description: Alternative ath10k firmware for QCA99x0 from Candela Technologies.\ Enables IBSS and other features. See:\ http://www.candelatech.com/ath10k-10.4.php \ This firmware conflicts with the standard 99x0 firmware, so select only\ one. \ \


Yes, after installing kmod-ath10k and ath10k-firmware-qca99x0 still no 5GHz radio

Just for curiosity let's see the output posted in preformatted text

ubus call system board

You're overdue for some fortune..

Default ath10k-ct packages were installed -

Reflash the router with the squashfs-sysupgrade image.