[SOLVED] Miktrotik snapshot to stock

Hello,

I have compiled and installed OpenWrt SNAPSHOT r6744-751746c successfully to my MikroTik RB951Ui-2nD as per the wiki. However I am now thinking of reverting to a stock image, so that I can install opkg packages without trouble.

Can I use sysupgrade to do this, or do I have to use TFTP boot and sysupgrade from there?

When I first used sysupgrade from SNAPSHOT r6744-751746c initramfs, after the reboot the router still had RouterOS installed. Is this because sysupgrade is broken in SNAPSHOT r6744-751746c, or because you have to do sysupgrade twice on Mikrotik?

LP,
Jure

The Wiki doesn't advise you to compile and install a snapshot, it suggests you download an OpenWRT image.

https://openwrt.org/toh/mikrotik/rb951ui
and
https://openwrt.org/toh/mikrotik/common

The short answer is yes, you can flash using sysupgrade...but it's a two-step process.

  • The ELF file must be used for TFTP and boot.
  • The BIN file is then used to flash using LuCI or sysupgrade once the ELF is booted.

You need both to properly flash and install OpenWRT on a MikroTik.

Also, it seems you forgot to clear the flash before proceeding.

And how is this accomplished?

LP,
Jure

Using the same method needed to boot the ELF.

On my RB433AH, the "RouterBOOT booter" is accessed using the serial port.

See section that says: From COM port on the links above.

Also see: https://wiki.mikrotik.com/wiki/Manual:Netinstall#OPTIONAL:_Configuring_RouterBOARD_with_COM_port

I used the TFTP / reset button method as my router has no serial port.

Is there a way to clear the flash from OpenWRT?

Also, why is this required? Isn't the flash cleared by the upgrade process?

I didn't say it was required. You asked:

I simply stated that you didn't clear the NAND - that is in the instructions. But I would advise that you clear the NAND since OpenWRT is looking at the partitions prior to flashing (e.g. partitions like kernel and rootfs).

If you can access LuCI from the booted ELF, you should be able to proceed with sysupgrade. If you're having an issue, its likely because you didnt clear the flash.

Well...let's see if the command ubinfo produces a result...This is slightly different from the MikroTik instructions, and I believe you may have a serial port inside the case.

root@OpenWrt:~# ubinfo
UBI version: 1
Count of UBI devices: 0
UBI control device major/minor: 10:59

I have reached my reply cap. Will try to follow your instructions and see how it goes.

EDIT: Tried it and sysupgrade persistently fails to change firmware in SNAPSHOT r6744-751746c. Unfortunately I don't see what the issue is as SSH connections are terminated during the flash.

Will try reset button / TFTP boot of http://downloads.lede-project.org/releases/17.01.4/targets/ar71xx/mikrotik/lede-17.01.4-ar71xx-mikrotik-vmlinux-initramfs.elf tomorrow.

LP,
Jure

Just for the record (and anyone else googling this subject) the image I linked is incorrect for my router which is RB951Ui-2nD (not RB951Ui-2HnD, which is a completely different model). The router I have really can only use snapshot images, as it requires the "openwrt-ar71xx-mikrotik-rb-nor-flash-16M-initramfs-kernel.bin" file, and the "mikrotik-rb-nor-flash-16M" images are not provided by version 17, but are provided by the current snapshot.

LP,
Jure

1 Like