[SOLVED] Meshing 2 Ubiquiti NanoHD with 802.11s (not working)

Hi there,

I'm trying to mesh 2 NanoHDs using 802.11s and I think I tried everything according to the Wiki and they don't connect to each other. They both use the mt76 driver, is there any limitation with it?

I confirmed they support meshing:

root@nanohd-downstairs:~# iw list | grep "Supported interface modes" -A 9
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 1:
--
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 1:

This is my main AP /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'
	option channel '1'
	option country 'AU'
	option cell_density '2'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key 'clave'
	option disassoc_low_ack '0'
	option ssid 'Order'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'VHT80'
	option country 'AU'
	option cell_density '0'
	option channel '157'
	option txpower '26'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option dtim_period '3'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option key 'clave'
	option ssid 'Chaos'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Mayhem'
	option encryption 'psk2+ccmp'
	option dtim_period '3'
	option disassoc_low_ack '0'
	option key 'clave'
	option network 'lan'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option disassoc_low_ack '0'
	option network 'lan'
	option dtim_period '3'
	option key 'clave.mesh'
	option mesh_id 'MessyDisaster'
	option encryption 'none'

And this is my secondary AP /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'
	option channel '1'
	option country 'AU'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'VHT80'
	option country 'AU'
	option cell_density '0'
	option channel '157'
	option txpower '26'

config wifi-iface 'defaultradio1'
	option device 'radio1'
	option mode 'mesh'
	option mesh_id 'MessyDisaster'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option dtim_period '3'
	option disassoc_low_ack '0'
	option key 'clave.mesh'
	option network 'lan'
	option encryption 'none'

It never connects, I tried using WPA3/SAE with wpad-mesh-openssl and with wpad-mesh-wolfssl.

What am I doing wrong? I don't think I'm missing anything. BTW, this is on 21.02.1.

Thanks heaps for any help in advance.

Update: Latest version of the /etc/config/wireless files.

All nodes in a mesh have to be on the same channel.

1 Like

Yes, you are right, in the wireless files I pasted they are not. Sorry for the confusion, in my tests, I can assure they all where in channel 157.

Another update, I just realised both devices are sharing the same BSSID:

Is it correct? Should not they have a different one? Can I force a different value somehow? I tried utilising option bssid but looks like it gets ignored?

SOLVED: Having the same BSSID on both APs was causing the problems. I had to force a different MAC
address on one of them with option macaddr for it to connect properly.

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'mesh-net'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lan'
	option macaddr '00:0C:43:26:60:38' # ensure its different to other nodes in the mesh network

To note, I don't understand why both have the same MAC address. Might be due to have to install OpenWrt in an usual manner utilising the console.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.