[Solved] Meraki MR33 uboot help

Hi all,

I recently acquired an MR33 and I'm attempting to follow the Google Drive instructions for installing OpenWRT, but having an issue in one of the first steps (flashing uboot). I'm by no means an expert in this sort of stuff, but I can usually figure out what needs to be done for a successful flash. Previously I have done this for the MR18, but the instructions are different enough that I'm having problems.

I'm using a Windows 10 machine and DSD TECH USB to TTL Serial Converter CP2102.

When I get to step 4 (Starting ubootwrite on the PC), I jump to the User Story: Flashing with Windows section later in the document. For me, the CP2102 COM port is 4, so start a CMD window in the directory of the mr33-uboot.bin files and I use the following command:

python ubootwrite.py --serial=COM4 --write=mr33-uboot.bin

However, after about 20-30 seconds I get the following response:

Prompt is Meraki
Found an error, so aborting

Not sure how to get past this. Any help would be very welcomed. Thanks in advance.

  • Are you running Python on Windows?
  • Are you executing the py file on the router console, or on the Windows machine?
  • Can you try this booting a Linux-based LiveCD/ISO instead?

Are you running Python on Windows?

I am using python, have version 2.7 installed as described in the Google Drive instructions.

Are you executing the py file on the router console, or on the Windows machine?

On the Windows Machine.

Can you try this booting a Linux-based LiveCD/ISO instead?

I was considering attempting with linux but was hoping there would be a quicker fix on Windows. I'll try the linux route tomorrow.


you may want to try a slightly different method as described here: https://forum.archive.openwrt.org/viewtopic.php?id=70514&p=2 post #43. As far as I remember, this method has a more verbose output.

I tried the Linux version of the instructions and got past my previous hurdle with no issues.

I'm now ssh'd into the MR33 and can access LuCi via a web browser.

But I have a new issue... I'm at the point where I need to decide to do either a "Permanent" install openwrt or a "Basic" install with a fallback. I'm attempting to follow the Basic/Fallback approach and replace "part.old" with the initramfs. The commands provided in the instructions are:

root@OpenWrt:/# file="path/to/openwrt-ipq40xx-meraki_mr33-initramfs-fit-uImage.itb"
root@OpenWrt:/# size=$(cat "$file" | wc -c)
root@OpenWrt:/# ubirename /dev/ubi0 part.old part.meraki.old
root@OpenWrt:/# ubimkvol /dev/ubi0 --size=$size --type=static --name=part.old

When I try the second command ( size=$(cat "$file" | wc -c) ) I get a "No such file or Directory" error. Like I said previously I'm not an expert in this stuff. The .itb file that the variable 'file' points to is what was used in the tftp process, and now that I'm SSH'd into the router it appears I need to find the location of where the .itb was saved. Is that correct? Is there a default location for tftp transfers?


Nvm, I figured it out. Sorry for my ignorance. After looking at this thread (post #45) I realized my understanding was correct (the .itb was only in RAM) and I needed to upload separately. I used SCP just like the other poster.

@whitehat09 If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

Do you know which version of u-boot your MR33 has? The latest u-boot version apparently has problems flashing, so I would be very interested if you managed to flash openwrt on the latest u-boot.

So I actually had two MR33's. One I accidentally plugged into the live network. The unit I successfully got to install openwrt on was the one that never left the box (U-boot 2012. something). I just tried all the same steps with the other unit and the python script does not work (windows or linux). The version of U-boot running on that is

U-BOOT 2017.07-RELEASE-g78ed34f31579 (Sep 29 2017 - 07:43:44 -0700)

Hope this helps. I'll hold on to this unit hoping that one day that uboot can be bypassed too.

i cant get in the Uboot olso (windows python 2.7 usb ttl) ...?
any help

  • In the future, you may wish to make another thread - this one is marked as solved
  • You need to provide more details and information about your problem - it's unclear what you're asking

im running windows 10 with python 2.7 ,and ive twoo Mr33 and i want to flash them with usb ttl i can see them bootup with Tera Term and throught cmd i can't get access to Uboot the MR33 ....please how can i get to the uboot mr33 ...?

Flow Control settings?

how to get to Uboot on mr33 so i can upload (mr33-uboot.bin) to it ..?
thanks for your fast answer

  • I just told you - it seems as if you can see the console; but not type. Check Hardware and Software flow control.
  • If you mean uploading the BIN, use TFTP.

okey i'll try that i'll check it thanks

1 Like

@hayman you marked this thread as solved; but noted to me in a message:

This means you booted into Meraki, boot again and be sure to STOP U-Boot before it boots Meraki OS.

1 Like

it's work thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.