[Solved] MC on OpenWrt for RPi

I'm trying to install Midnight Commander on OpenWrt for Raspberry Pi but am unable to do so.

opkg_install_cmd: Cannot install package mc.

Did you run this command first?

opkg update

root@OpenWrt:~# opkg --help
opkg: unrecognized option: help
opkg must have one sub-command argument
usage: opkg [options...] sub-command [arguments...]
where sub-command is one of:

Package Manipulation:
update Update list of available packages

BTW, no argument is needed with opkg to display the help menu.

I did run opkg update first.

  • Did it succeed or fail?
  • What version of OpenWrt are you running?
  • Are you using the device as a normal router or something else (like an AP)?

It worked.

15.05.1 - that's the latest I could find for the RPi

I'm hoping to set it up as an AP.

I just built myself a new img - SNAPSHOT, r7402-0f543883cd (whatever that means) and using that I was able to

opkg install mc

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Do I need to edit the title of the thread and prefix it with [Solved]? I don't see an Icon for doing this..

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.